I have a Raspberry Pi2 B+ model, with noobs distro installed.

I had some programs using wiringPi library and an ultrasound component working (tested them using a separate monitor via HDMI). However, after connecting the official Raspberry Pi touch screen display these programs are not working anymore.

On further analysis I realized that the ECHO signal from same ultrasound device was never captured (checked using voltage value on one of the INPUT mode GPIO pins)

Referred to questions: GPIO pins NOT working when using touchscreen and Touchscreen drivers disable GPIO interface in Python

However, I don't think this is the problem because if I disconnect the touch screen and plug in HDMI again, the same programs with same ultrasound connections work flawlessly. (Note: also tried a simple LED program, but that doesn't work either)

Any ideas? The questions I referred to mentioned that the drivers for touchscreen might have disabled the kernel level access for GPIO library (Python library in those questions, wiringPi C library in my case) I just did a full update and upgrade from apt-get to get the screen working, no special drivers installed separately.

1 Answer 1


Have you tried a fresh raspbian jesse instead of updating? And are all the flatcables connected in the screen. I had a couple delivered to me where the smallest cable was disconnected from the board.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.