I've a Raspberry Pi B+ and I've set the autostart file to run VNC after boot.

I connect the USB Dongle and it works perfectly. It connects to the Wi-Fi automatically (with previous set of network SSID and pass key). I used to control my Raspberry using VNC Viewer in Windows 8.1 and a hotspot Wi-Fi from my laptop and no problems were found.

I replaced the hotspot network, of my laptop, with an access point in order to connect the laptop and the Pi.

My problem is that VNC Viewer stops working and gives an error

connection refused : 10061

although the IP is correct and I ensured that it's true by using ping.

Why was it connected by the hotspot network but not when using the access point? Why does VNC stop when the two devices join the same network?

1 Answer 1


I have fixed my problem ... by stop power management ... it has disconnecting raspberry pi

Make a file 8192cu.conf in directory /etc/modprobe.d/ with the command

sudo nano /etc/modprobe.d/8192cu.conf

and add the following lines

# Disable power management
options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

thanks for everyone


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.