3

The error message I am getting is:

[40%] Built target opencv_video
Makefile:137: recipe for target 'all' failed
make: *** [all] Error 2

I have looked around, and people said that it might work with cmake -D WITH_IPP=OFF, but it does not seem to work.

Anyone that has succeeded in installing OpenCV on RasPi3, can you help me out? Or, I would like to know if RasPi3 is not compatible, for example.

1

I had the exact same issue when I went to install OpenCV 2.4.9 on my Raspberry Pi 3. Interestingly enough, OpenCV 3.0.0 worked okay, so if you were installing that then I can't help. For me, disabling ffmpeg in the cmake options fixed the issue. Here is the command I used:

cmake ../ -DWITH_FFMPEG=OFF

Followed by the standard make and install.

Edit: also, I had tried installing ffmpeg in the past and installing OpenCV 2.4.9. This also failed. It is possible I messed up the ffmpeg install because I only tried it once. If you need ffmpeg, you may have to sort out some deeper issue yourself.

| improve this answer | |
-1

Using

cmake ../ -DWITH_FFMPEG=OFF 
make
make install

works for me !

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.