I just got the Raspberry Pi 3 and when it boots up Raspbian I can click on the menu, epiphany, or any of the top icons, however, if I open anything, say for example epiphany, I cannot click on any of the buttons inside the browser only the keyboard works for the browser. I can still click on the top toolbar though.

What is really confusing is that if I hit enough buttons randomly do something I can switch and click on anything in the browser, but then I cannot click on any buttons in the top toolbar. This occurs for any window I open.

I have spent hours trying to figure out what gets it to do this. I have tried reinstalling Raspbian this time without NOOBS and I still get the same result. Google has been unhelpful as well for the first time in my life.

Any thoughts would be greatly appreciated.

  • I have the same issue, did you end up fixing this? Commented Apr 25, 2016 at 23:27

2 Answers 2


Updating Raspbian

Since you've already tried doing a reinstallation of Raspbian, you may not be on the latest version of your OS, causing your errors. You can update by executing the following through LXTerminal:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo rpi-update
sudo reboot

-wait for reboot-

sudo branch=next rpi-update
sudo reboot

-wait for reboot-

This should update your Raspberry Pi to the latest edition that the Pi Foundation provides.

Installing a New Browser

You can also try installing the browser singularly by executing the following:

sudo apt-get install epiphany-browser

This should update your browser if it wasn't on it's latest version.

If this still fails to solve your problem, try installing Chromium, an open-source equivalent to Chrome that shares similar coding:

wget https://launchpad.net/~canonical-chromium-builds/+archive/ubuntu/stage/+build/7916060/+files/chromium-browser_45.0.2454.85-0ubuntu0.
wget https://launchpad.net/~canonical-chromium-builds/+archive/ubuntu/stage/+build/7916060/+files/chromium-codecs-ffmpeg-extra_45.0.2454.85-0ubuntu0.
sudo dpkg -i chromium-codecs-ffmpeg-extra_45.0.2454.85–0ubuntu0. chromium-browser_45.0.2454.85–0ubuntu0.

and then

sudo apt-get install -f

and then

sudo dpkg -i chromium-codecs-ffmpeg-extra_45.0.2454.85–0ubuntu0. chromium-browser_45.0.2454.85–0ubuntu0.

There are also other browsers that are compatible with the Pi, shown on this website.

Last Resort

If you've tried all of these and still no luck, try to format your MicroSD card fully and then re-install NOOBs, then following up with Raspbian. Remember to backup all important files before doing so.

EDIT: This could also be an error with your keyboard/mouse. You could try it on a different computer to see whether or not that is the issue.


Had the same issue just now and it might've been caused by:

  • Installing RealVNC to remotely access RPi (most probably that's the reason as it hijacks mouse and keyboard)
  • Attaching camera to RPi (doubt it, but I mention it just in case someone wants to investigate further)

After that my mouse went crazy and would only ocassionaly work and for most of the time didn't switch focus (same after connecting to RealVNC).

I didn't debug it thoroughly but after removing mouse/keyboard/HDMI and using RealVNC exclusively everything went back to normal.

So, if you have the same issue either switch to RealVNC like I did, remove it completely and see if it works or just try to debug further.

Hope it helps someone, cheers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.