I used the command $ sudo apt-get install chromium and it didn't work. I'm using Raspberry Jessie. When I ran the command I got this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package chromium is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  chromium-inspector chromium-bsu

E: Package 'chromium' has no installation candidate
  • 1
    Side note: the error message you're seeing is due to the fact that chromium package originally belonged to a game created around year 2000. Its package was since renamed to chromium-bsu to avoid confusion with the new browser, which was incidentally packaged as chromium-browser. Commented Oct 12, 2016 at 8:54

5 Answers 5

wget https://launchpad.net/~canonical-chromium-builds/+archive/ubuntu/stage/+build/7916060/+files/chromium-browser_45.0.2454.85-0ubuntu0.
wget https://launchpad.net/~canonical-chromium-builds/+archive/ubuntu/stage/+build/7916060/+files/chromium-codecs-ffmpeg-extra_45.0.2454.85-0ubuntu0.
sudo dpkg -i chromium-codecs-ffmpeg-extra_45.0.2454.85–0ubuntu0. chromium-browser_45.0.2454.85–0ubuntu0.

and then

sudo apt-get install -f

and then

sudo dpkg -i chromium-codecs-ffmpeg-extra_45.0.2454.85–0ubuntu0. chromium-browser_45.0.2454.85–0ubuntu0.
  • 5
    IMHO this is a bad advice as it neither verifies the downloaded file nor does it care for security updates, i.e. leaves the user with an outdated and possibly vulnerable web browser rather quickly. Using that Ubuntu repo seems to be a good advice in general, though. Commented Mar 25, 2016 at 19:00

It's in the raspberrypi.org repository for Raspbian now.

sudo apt-get install chromium-browser
  • Can somebody confirm this? I can't see it in Jessie. There's a chromium-browser in wheezy, which is really old (version 22.0) and should not be used IMO. Commented Oct 12, 2016 at 9:04
  • 1
    It's all I used when installing onto a Jessie Lite image and is working fine.
    – Ben Cline
    Commented Oct 16, 2016 at 20:20
  • 2
    Could you tell what you have in /etc/apt/sources.list? Commented Oct 17, 2016 at 9:22
  • 2
    Yes, I can confirm that. It's just not in the raspbian.org APT repository but in the one at archive.raspberrypi.org/debian i.e. in the Raspberry Pi Foundation APT repository for Raspbian. I've submitted an according clarifying edit for the answer above. So if you don't have that additional APT repository, you won't see it. Commented Oct 18, 2016 at 12:25

This answer is outdated and should no more be followed. See https://raspberrypi.stackexchange.com/a/56231/42933 for—since October 2016—the most appropriate answer.

As already shown in the previous answer, the general idea is to use Chromium builds from Ubuntu. Using their staging repository for Chromium security updates is probably not the only way, but not a bad choice either:

  • Always up-to-date.
  • Only contains Chromium and doesn't contain any unrelated packages.

To add that PPA to your Raspbian Jessie or Debian Jessie on a Raspberry Pi 2 or 3 (won't work on the Raspberry Pi 1), add the vivid version of https://launchpad.net/~canonical-chromium-builds/+archive/ubuntu/stage to your /etc/apt/sources.list or create a new file at /etc/apt/sources.list.d/chromium-ppa.list with the following lines (source repository commented out as by default on Raspbian):

deb http://ppa.launchpad.net/canonical-chromium-builds/stage/ubuntu vivid main 
#deb-src http://ppa.launchpad.net/canonical-chromium-builds/stage/ubuntu vivid main 

Ubuntu 15.10 Vivid is the Ubuntu release which is closest to Debian/Raspbian 8 Jessie and hence doesn't need any additional non-Raspbian/-Debian packages to be installed to fulfill dependencies. (Ubuntu 15.04 Vivid itself is no more supported, but Chromium builds are still generated for it for some reason unknown to me. If that stops, you might want to switch to either Ubuntu 14.04 LTS Trusty or Ubuntu 15.10 Wily and install the few additional dependencies from normal Ubuntu repositories.)

To being able to verify the downloaded packages, you need to import the according GnuPG key into APT. By using the full fingerprint as key-id when downloading and importing the key you can be as sure to have the right key as with comparing the fingerprint after downloading:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys DB69B232436DAC4B50BDC59E4E1B983C5B393194

Please verify the above fingerprint against the one published on https://launchpad.net/~canonical-chromium-builds/+archive/ubuntu/stage to be sure to allow the right key to install packages on your system.

Finally you just need to update the package list and install the chromium-browser package:

sudo apt update
sudo apt install chromium-browser

After that you can already call chromium-browser on the commandline. But to see it also in the menu, etc., you might want to log out and in again or just reboot.

  • 2
    +1 for a solution that updates itself. I only knew previously about the method described in the other answer.
    – tjohnson
    Commented Apr 30, 2016 at 21:52
  • 1
    After clicking on the link, I'm not sure if this is a good idea. According to the PPA description, "Things here are either new and broken and not ready to use, or landing in the distro anyway in a few days. You shouldn't use this unless asked to."
    – tjohnson
    Commented May 26, 2016 at 0:24
  • After following these install instructions, I have a working Chromium browser that doesn't load images from many sites (including twitter). I suspect it might be related to loading images over SSL. Any ideas what's up? Commented Aug 31, 2016 at 12:59

Axel Beckert is correct in his answer, however any version of Chromium after 48 wont run on armhf (which is what Raspberry Pi 2 & 3 use) because of this bug: https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1563184

To correct this I modified DolbyOver's answer as follows:

wget https://launchpad.net/~canonical-chromium-builds/+archive/ubuntu/stage/+build/8883797/+files/chromium-browser_48.0.2564.82-0ubuntu0.
wget https://launchpad.net/~canonical-chromium-builds/+archive/ubuntu/stage/+build/8883797/+files/chromium-codecs-ffmpeg_48.0.2564.82-0ubuntu0.
wget https://launchpad.net/~canonical-chromium-builds/+archive/ubuntu/stage/+build/8883797/+files/chromium-codecs-ffmpeg-extra_48.0.2564.82-0ubuntu0.
wget https://launchpad.net/~canonical-chromium-builds/+archive/ubuntu/stage/+build/8883797/+files/chromium-chromedriver_48.0.2564.82-0ubuntu0.

sudo apt-get install -f

sudo dpkg -i chromium-codecs-ffmpeg_48.0.2564.82-0ubuntu0. chromium-codecs-ffmpeg-extra_48.0.2564.82-0ubuntu0. chromium-chromedriver_48.0.2564.82-0ubuntu0. chromium-browser_48.0.2564.82-0ubuntu0.

Use this method until the bug above has been fixed.

  • 1
    This worked like a charm on my Raspberry Pi 3. Thanks! Commented Sep 13, 2016 at 18:37
  • Still the same issues as with the first answer apply: The downloaded packages are not verified at all. Commented Oct 18, 2016 at 12:34
  • I agreed with you, as you may have noticed. But until the problem is ACTUALLY / PROPERLY resolved people have little choice here
    – th317erd
    Commented Feb 6, 2017 at 19:12
  • As of August 2017, chromium-browser package on raspbian Stretch matches the latest available version (Chromium 60)
    – Quentin S.
    Commented Aug 26, 2017 at 16:35

Ben's answer about raspberrypi.org repos didn't work for me because it tries to pull in raspberrypi-bootloader and other packages that I wasnt willing to install.

What I ended up doing is pull Chromium from Ubuntu, but through the package manager to have updates and verification.

I'm using jessie and trusty as of today, but it should work for newer releases as well.

  • Add trusty repos:

    deb http://ports.ubuntu.com trusty main universe multiverse
    deb http://ports.ubuntu.com trusty-updates main universe multiverse
  • Setup default release for apt:

    echo 'APT::Default-Release "jessie";' > /etc/apt/apt.conf.d/10release
  • Add Ubuntu keys to apt's truststore:

    apt-key adv --keyserver hkp://keyserver.ubuntu.com --recv-keys 40976EAF437D05B5 3B4FE6ACC0B21F32
  • Update and instal

    apt-get update
    apt-get install chromium-browser/trusty chromium-browser-l10n/trusty chromium-codecs-ffmpeg-extra/trusty

Using -t trusty instead of /trusty might be preferrable in some cases (e.g., you want to pull in all dependencies as well)

Not the answer you're looking for? Browse other questions tagged or ask your own question.