1

I just purchased an Eleduino 1024x600 IPS HDMI Capacitive touchscreen, assembled it, powered it with external USB (a Pi2's USB was unable to keep it on), and tried the following using a Redmere HDMI cable:

  • Pi2, booting into a text console login
    • Static patterns
  • Pi3, console login
    • Blinking vertical thick line
  • Pi3, starting at console login as before, then hit enter on startx
    • white with vertical lines; lines shift when mouse moved
    • fine low-resolution display when switched back to a real monitor
  • Pi2 with /boot/config.txt set to hdmi_safe = 1, framebuffer_width=1024, framebuffer_height=600,config_hdmi_boost=4 uncommented
    • blackish pattern

Note that the NOOBS boot puts differing patterns of lines on the screen until it hits the console, instead of the normal color pattern followed by an option to go into recovery.

  • WRT to Pi +/2 models and USB power, see here. – goldilocks Mar 20 '16 at 14:25
  • That's why I said I powered it with external USB. – Anti-weakpasswords Mar 20 '16 at 20:14
  • My point was if you set it max_usb_current=1, it probably will work without a hub. This makes the difference between, e.g., being able to power an external HDD and not being able to (without a hub). But it the screen doesn't work then of course it doesn't matter. – goldilocks Mar 20 '16 at 23:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.