6

I am trying to connect the ADA Fruit USB to TTY cable to a Mac with Mac OS X 10.11.3. I installed the driver and see /dev/tty.usbserial but when I try screen /dev/tty.usbserial 115200 I get no output on the screen.

Below a picture of my wiring. wiring of use to tty cable

Any recommendations on how to wire the cable?

Update

I checked a tutorial to verify whether I had to configure anything on the host side. It looks like I have /dev/ttyAMA0 on ArchLinux, and ls -l /dev/ttyAMA0 returns

 crw-rw---- 1 root uucp 204, 64 Feb 22 09:40 /dev/ttyAMA0

note: I switched the cables in the right order before doing this.

Update 2

I added

dtoverlay=pi3-disable-bt
dtoverlay=pi3-miniuart-bt

to /boot/config.txt. When I power off the Raspberry Pi 3 and disconnect the tty USB cable, reconnect the USB cable and power on the RPI 3 I get a boot message and login prompt but whatever character I type do not get shown on the display.

I followed the guidelines on the ArchLinux wiki to set up a serial tty. I typed sudo systemctl status serial-getty@ttyAMA0.service and get,

* serial-getty@ttyAMA0.service - Serial Getty on ttyAMA0
   Loaded: loaded (/usr/lib/systemd/system/serial-getty@.service; enabled; vendor preset: disabled)
   Active: active (running) since Wed 2016-03-23 12:12:15 EDT; 5min ago
     Docs: man:agetty(8)
           man:systemd-getty-generator(8)
           http://0pointer.de/blog/projects/serial-console.html
 Main PID: 218 (agetty)
   CGroup: /system.slice/system-serial\x2dgetty.slice/serial-getty@ttyAMA0.service
           `-218 /sbin/agetty --keep-baud 115200 38400 9600 ttyAMA0 vt220

Mar 23 12:12:15 stereos-pi systemd[1]: Started Serial Getty on ttyAMA0.

Any pointers on what is happening or how I could debug this?

Update 3

I did the exact same with Raspbian and I get a good working connection.

  • 1
    The Raspberry Pi3 dedicates the usual UART to Bluetooth. Another UART is used instead with the unfortunate consequence that the baud rate changes with core clock frequency. I know you are meant to be able to set the core clock frequency to 250 MHz to get around this problem. There seem to be other related problems as well. Look in the raspberrypi.org forums for the latest information as it's not something I have followed closely. – joan Mar 21 '16 at 9:30
  • Any clues on how I could change this? – Stereo Mar 21 '16 at 13:03
  • 1
    there is pi3-miniuart-bt overlay which allows pl011 to be free again. github.com/raspberrypi/linux/tree/rpi-4.1.y/arch/arm/boot/dts/… – edo1 Mar 21 '16 at 13:14
  • Also this thread is for Android Things OS, it has some Rpi3-related setup instructions along with the official documentation regarding config.txt parameters. – Onik Aug 16 '17 at 15:30
3

From the looks of it your rx and tx lines are the wrong way around, try swapping them (the green and white wire).

Note that if you try to connect to the serial line after your pi has booted you will not see anything on the screen until the pi writes something to the serial line. If there is a tty listening then hitting enter should cause the pi to send some data. Otherwise rebooting the pi should show the boot messages on the serial by default.

As an aside, I generally leave the power (red) cable unconnected and out the way. It is not needed if you pi is powered via the normal connector, stops the pi leeching power from your computer's usb (which might only support at most 500mA) and keeps your computer better isolated from the pi should anything go wrong (such as a short on the pi).

  • Thanks for your input, I tried to rewire and when I press enter nothing happens. Is it possible to have a unix command line on the serial? – Stereo Mar 21 '16 at 4:51
  • it should be by default in raspbian – edo1 Mar 21 '16 at 13:15
2

Hello I assume you have installed required driver for USB to TTY , and in your MAC you have to connect throw this command line : screen /dev/cu.usbserial 115200 But before doing that (and just for raspberry pi 3) you must add the following lines to the file /boot/config.txt :

enable_uart=1

dtoverlay=pi3-disable-bt

dtoverlay=pi3-miniuart-bt

core_freq=250

Edit after that the file /lib/systemd/system/hciuart.service and

replace /dev/ttyAMA0 with /dev/ttyS0

If you have a system with udev rules that create /dev/serial0 and /dev/serial1 (look if you have these one), and if so use /dev/serial1 Look at this video : https://www.youtube.com/watch?v=RkOtub1H944

  • With adding the 4 lines, I can get response from command window. The command to replace ttyAMA0 with ttyS0 seems make no sense to me. – Dennies Chang Mar 6 '18 at 11:25
1

I always have success with the following simple process.
After burning a new SD card (or the one in problem), using windows notepad++ or any other alternative method, open the config.txt on the new card FAT partition directory. On windows, this is the first partition, the second is not directly readable and windows will ask to reformat (Ignore!).
At the bottom, add the following two lines :

core_freq=250
enable_uart=1

config.txt is a linux file, using the regular notepad will add extra chars on every line.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.