6

Has anyone been able to get the analog audio to work in KODI on the Pi2? It works great through HDMI but I want to install this in my wife’s minivan and it only has component inputs, no HDMI. I am using the correctly configured (and tested) cable in the 3.5 jack. I get great video but no audio. I’ve tried every combination of settings in the System/Settings/Audio Menu including changing the output to ‘analog’ and ‘HDMI and Analog’ still nothing. I do, however, get a nasty buzzing sound when I select Pass-through so the audio is responding, it’s just not playing anything, no movies, no music, no system sounds. Any ideas?

  • 1
    Good to see you've already received at least one answer. Having played around a little with the analogue audio out on the Pi, it's not exactly the most gloriously pristine signal I've ever treated my ears to. You can sidestep your issue using something like this bus powered Tendak HDMI -> VGA converter with 3.5mm analogue audio out. I found the Pi's HDMI audio out a little more pleasant than the 3.5mm audio out. Converter does bulk the Pi out a little though. – goobering Mar 22 '16 at 13:33
  • Thanks for the tip. I have actually ordered something similar to this in case I can't find a solution. I'll see how it goes and reply back. – megalodon Mar 22 '16 at 13:45
  • 1
    @goobering is probably making a good suggestion here, because the audio quality really isn't very good from the 3.5mm headphone jack. There is some more helpful info what to do to get any audio-output here: raspberrypi.stackexchange.com/questions/44/… – Chris Mar 23 '16 at 5:19
5

You must edit your config.txt in boot partition. Set:

hdmi_ignore_edid_audio=1
hdmi_force_edid_audio=0

This will force audio due analog output. After changes reboot your device.

You can read more about it in documenation at: https://www.raspberrypi.org/documentation/configuration/config-txt.md

  • Unfortunately this did not work. Still silence. I'm probably going to go with the solution above. – megalodon Mar 23 '16 at 13:33
3

Actually, in a recent version of kodi (using openelec build 8.0.0 for the raspberry 3, which is kodi 17) there is an option to select the audio output under

settings -> system settings -> audio

and one can select either hdmi, analogue (3.5mm jack), both or pulseaudio (which can be used for e.g. bluetooth)

  • Note: it might be necessary to also set "Output configuration: fixed" at the same screen – Piskvor Jul 10 at 22:36
0

The solution (for me) was to calibrate my screen. Because I was too focused on getting the audio to work I didn't calibrate my screen. the top and bottom were cut off and I didn't see the 'Mute' Icon in the top-right corner. During the setup stage, I must have hit the F-something key that mutes Kodi. After setup I just used the iOS remote App which does not have a mute function, just vol control. Also, Mute has no effect on HDMI pass-through so all of my HDMI tests passed. I plugged my keyboard back in, unmuted Kodi and all is well.

Now I know, Calibrate your screen.

0

You don't have to disable HDMI-out to use analog audio out. You can actually use both without messing with config files.

I use "Audio Profiles" plugin within KODI to switch between HDMI audio out for video-playback and analog audio out for music-playback. Works great for me and was easy to set up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.