0

When I create any file, like .bash_aliases for example, and then I reboot using sudo reboot, all my changes are lost. I don't know if the card is read-only (I can actually create files).

I am running under Raspbian Jessie and I've been looking around for a solution. One I tried that did not work was to add a 'rw' before the waitreboot in /boot/cmdline.txt.

Does anybody have another idea how to fix this?

  • 1
    Did you do as the top said and press enter when saving? I wasn't saving my file for a while until I learned how to do it. – FivePixels Mar 22 '16 at 18:23
  • What editor are you using to create the files? – joan Mar 22 '16 at 18:48
  • I use nano, and I ctrl-x / Y to save and quit. I have reinstalled Raspbian, I'll test tonight and report here after I've tried again! – Flag Mar 23 '16 at 7:05
  • I have same problem on all small file (seems to be a cache problem): all change are lost after reboot. I try different SD cards but same issue. Very simple to test: change same lines in /boot/config.txt, save and reboot... result: all change lost. – user44606 Apr 8 '16 at 10:23
  • Anybody got a workaround for this? – Peter Aug 3 '17 at 13:33
0

Ok, so according to this post it seems that can happen when the card gets corrupt.

  • Could you please include relevant information from the link in your answer, in case the link breaks in the future. – Darth Vader Feb 19 '18 at 9:02
  • Well that's it really, the card is corrupt :) Just get a new one. – Flag Feb 20 '18 at 10:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.