2

I got an RPi 3 up and running yesterday and turned it on. It seemed to work fine, but after a while it randomly rebooted, I don't believe I caused it to happen. So I didn't think much of it until it happened again, and then again awhile later.

I'm not sure what could be causing this, though I believe the SD card needs to be changed slightly for use in the 3. I don't know why that would affect it.

Would the card affect it? If not what would be doing this?

  • 1
    The standard guess is that it's a power issue. The RPi 3 is a hungry, hungry hippo, and it gets unhappy if you don't feed it properly. Do the logs indicate anything useful? – Jacobm001 Mar 22 '16 at 22:03
  • Where are the logs? – sir_ian Mar 22 '16 at 22:04
  • /var/log/syslog would be the best place to start, normally. – Jacobm001 Mar 22 '16 at 22:05
  • ... on any reasonable linux journalctl will be your friend. – Ghanima Mar 22 '16 at 22:09
  • What does /lib/udev/mtp-probe do? It looks like whatever the problem was it started there. – sir_ian Mar 23 '16 at 0:49
4

I have seen this happen with my Raspberry PI 3. My pi was drawing too much power when under heavy load, crashing and then restarting.Since the PI 3 uses around 1.34 amps under max stress, my 2.0 USB port was not powerful enough to run some applications i requested from it and this could be what you are experiencing.

A few things you could do to test this could be to leave your pi idling. If it still crashes then it is most likely an OS problem and a fresh install/upgrade should resolve any issues. But if this still does not fix the problem then you are not supplying it with enough power.

Power Usage Reference: https://www.raspberrypi.org/help/faqs/#powerReqs

4

My RPi 3 restarted like this as well.

I was using my older power supply which had 5v/2 amps or something similar. I switched to a newer power supply which had 5.25v/2.4 amps and the problem went away. I think that the new quad core just uses a little more power.

2

For me the problem was this: https://www.raspberrypi.org/forums/viewtopic.php?f=91&t=122601

So after commenting out this chunk of /etc/rsyslog.conf the Pi is not doing unexpected rebootings anymore (which caused the broken pipe ssh freeze):

daemon.*;mail.*;\
       news.err;\
       *.=debug;*.=info;\
       *.=notice;*.=warn       |/dev/xconsole
-1

Yes, It's a low voltage issue...try another power adapter...(i used samsung> 5v - 1.55A and it works)

  • This adds little to the existing answers. And provides no pertinent facts. – Steve Robillard Dec 23 '16 at 8:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.