4

I have problems when trying to update the apt repositories.

pi@raspberrypi:~ $ sudo apt-get update
Err http://mirrordirector.raspbian.org jessie InRelease

Err http://mirrordirector.raspbian.org jessie Release.gpg                      

W: Some index files failed to download. They have been ignored, or old ones used instead.
  • Are you connected to a network? – Bex Mar 23 '16 at 9:46
  • try ping www.google.com to see if you are connected to the network or not. – Shan-Desai Mar 23 '16 at 11:16
  • am sure that am connected to the network ,i got ths : """64 bytes from par03s14-in-f14.1e100.net (216.58.211.78): icmp_seq=43 ttl=49 time=100 ms 64 bytes from par03s14-in-f14.1e100.net (216.58.211.78): icmp_seq=44 ttl=49 time=99.8 ms 64 bytes from par03s14-in-f14.1e100.net (216.58.211.78): icmp_seq=45 ttl=49 time=98.5 ms 64 bytes from par03s14-in-f14.1e100.net (216.58.211.78): icmp_seq=46 ttl=49 time=96.5 ms 64 bytes from par03s14-in-f14.1e100.net (216.58.211.78): icmp_seq=47 ttl=49 time=95.7 ms 64 bytes from par03s14-in-f14.1e100.net (216.58.211.78): icmp_seq=48 ttl=49 time=97.0 ms – happy Mar 23 '16 at 11:25
  • 1
    Try a different mirror. Your network may be blocking your current one. – FivePixels Mar 23 '16 at 12:54
5

There is DNS related issues with mirorrdirector. See answer here : cannot connect to mirrordirector.raspbian

You can remove

deb http://mirrordirector.raspbian.org/raspbian wheezy main firmware

from /etc/apt/sources.list then add another mirror found here to this file.

Or, you can change /etc/resolv.conf to something like :

nameserver 8.8.8.8 
nameserver 4.4.4.4
  • I got ths error after changing /etc/apt/sources.list : W: Some index files failed to download. They have been ignored, or old ones used instead. E: Write error - write (28: No space left on device) E: Can't mmap an empty file E: Failed to truncate file - ftruncate (9: Bad file descriptor) E: The package lists or status file could not be parsed or opened. – happy Mar 23 '16 at 18:56
0

Fixed mine just if you edit "sudo nano /etc/dhcpcd.conf" and have manually IP Static Config Settings the line for "static domain_name_servers=192.168.x.x 8.8.8.8" for example. Save and reboot. Remember 192.168.x.x is Your Local Router/Gateway IP Address. This works for me!

  • It's fine that setting a static IP helped in your case, but do you have any indication that the OP has the same problem? – RalfFriedl Feb 16 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.