0

I just got an RPi 2. I'm using NOOBS. I want to connect the RPi to a small screen I bought that takes NTSC composite input. For now, I'm testing on my TV, which has HDMI and composite inputs. I tried modifying /boot/config.txt to include sdtv_mode=0 and sdtv_aspect=1 and rebooting, but I still only got a signal over HDMI. I checked that the cable I'm using matches the diagram at this diagram using a multimeter. The sleeve of the TRRS connector connects to the connector pin of the red RCA connector and ring 2 of the TRRS connects to the outer ring of all three RCA connectors. If I run sudo tvservice -c "NTSC 4:3" (per this question), the HDMI stops working (which I expected), but the result was a dark screen on the composite video. It's not no signal. Everything is just black. I guessed that terminal is still open, and if I run sudo reboot now (though I can't see what I'm typing), I momentarily see the raspberry logo over the composite video connection, then a blinking cursor, then the RPi reboots in HDMI mode.

How can I get this to work in NTSC? Thanks!

3

The raspberry pi should never be run with both composite and hdmi cables as it will never run both simultaneously and the hdmi cable should always take priority by default. Furthermore it is a very common problem that people mixup audio and video composite cables as the pinout is different for the raspberry pi when compared to something such as a camcorder so please ensure that you are using not only a complatible cable but also that the pin closest to the outside of the pi is the one that is being connected to the yellow jack on your tv. The step by step instructions below may help you

  1. As it seems that you already have an os installed please enter the config file /boot/config.txt
  2. Look for the line below
    #sdtv_mode=0
  3. Remove the leading hashtag from that line and change the trailing zero from that end of that line to one of the following based on the type of tv you own
    1. sdtv_mode=0 for standerd NTSC (the one you want)
    2. sdtv_mode=1 for the japanese standard version of NTST
    3. sdtv_mode=2 For standard PAL
    4. hdtv_mode=3 for the Brazilian version of PAL
  4. Add the following line to the file:
    hdmi_ignore_hotplug=1
  5. Ensure that the following line
    hdmi_force_hotplug=1
    is commented out(with a hashtag placed before the line.)
    see example below:
    #hdmi_force_hotplug=1
  6. Save your changes
  7. Reboot your Pi with only your composite device plugged in and ensure that the display is on before your pi, Furthermore please ensure that nothing is connected to the hdmi port as this may take boot priority and prevent the pi from loading the composite display.
  • Thanks! I didn't know about the hotplug settings and the priority for HDMI. It's working now! – Don 01001100 Mar 26 '16 at 5:29
  • Not a problem, and thank you for giving me the opportunity to share my knowledge, on this forum for the first time. Best of luck with your pi. – Mohammad Ali Mar 26 '16 at 5:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.