I opened a terminal window using the launch bar icon (next to the "Menu" button on Jessie) and typed in sudo apt-get install omxplayer. After doing its thing without errors, it said that I already had the latest version and that nothing was installed. I looked through the main menu editor, but couldn't find it.

When I installed sdlbasic the same way, it showed up automatically in the main menu under PROGRAMMING. Likewise, I did sudo apt-get install for Iceweasel, and it was right there under INTERNET. But when I tried omxplayer and motion, I couldn't find them.

How do I find and run them?

  • 2
    you can run them from the commandline Mar 27, 2016 at 3:10

3 Answers 3


The thing about Omxplayer is that it is MEANT to be run from a command line. There is no "official" GUI for it as of yet. To run omxplayer, open a terminal and use cd to move to which folder has your media. Then, use the command

omxplayer myfile.mp3

Or such. Some common options are: -b (black background instead of Desktop) -o local:hdmi (choose where the audio comes from; headphone jack or HDMI)

Hope this helps :)


Open a terminal and try typing, omxplayer. It should start, or perhaps the program has a different name from its package.

  • When I type that in, it just prints out a "cheat sheet" of like options & parameters you can adjust (fullscreen, fps, audio pass through etc), but can't get anything else to come up. I even tried reading the man pages for man itself, so I've got to find out what the number in parenthesis means, and find myself learning about Lexical Analysis so I can understand how this command will help me filter instructions after I find out what lexical means. But seriously, now I need help not with omxplayer, but with its man page. I'm trying to view an IPcam, so where do I enter the IP addess, port#, etc
    – user39664
    Mar 28, 2016 at 0:01
  • Your question has been answered. If you have a specific question about using omxplayer you should start a new question, and mark one of these as and answer, upvoting ones that were useful
    – dbmitch
    Jun 22, 2016 at 19:34
  • @dbmitch You are right, the question I posted was indeed answered, and I just accepted one by clicking the "check-mark" icon, which then turned green (I had to ask on meta to learn how to do that). Since you've been helpful to me by offering (remedial?) guidance, could you help ease some learning-related confusion I have regarding upvoting? Is that done by clicking the icons above the color changing check mark I just mentioned? Are there any reputation or badge requirements I must meet? Is upvoting limited to a single response, or is it rated like say the 1 -> 5 STARS system like on Netflix?
    – user39664
    Jul 19, 2016 at 5:05
  • I can't answer those questions but you can try the Meta group or the Help section. I'm fairly new here and just try to help who I can - as well as get my own questions answered
    – dbmitch
    Jul 19, 2016 at 5:36

not all programs that you install create a shortcut in the menu automatically. the answer how to open it you have already but if also want to get it into the menu try LXMenuEditor if you are using LXDE.

  • If I am using LXDE, then try LXMenuEditor? I don't know what LXDE is. Is that the menu itself, and to edit it, use LXMenuEditor? Or are referring to my question where I look through the main menu editor? I was running Raspbian Jessie, and I think the menu editor was called "alacarte". I never know if I'm not doing something, or I'm doing something wrong, or if it's a bug, but I would set things up how I liked, then turn around and it would be back to its initial settings. I kept fighting with it, but finally gave up. Now I've gone back to Wheezy, it says I didn't set the locale, but I DID!
    – user39664
    Mar 27, 2016 at 22:09
  • dont give up that fast. i thought you use LXDE as its probably the most used desktop for raspbian. if you still have the os running somewhere you can try to open a terminal and type: echo $DESKTOP_SESSION to see what desktop you use... im pretty sure its lxde or xfce. both have friendly possibilities to add menu shortcuts. im happy to help if you decide to fall back to jessie?! also on wheezy. it would be good to know what desktop you use. than im sure me or someone other can help you on this. Mar 28, 2016 at 1:08
  • I pasted "echo $DESKTOP_SESSION" into the terminal that comes up (LXTerminal 0.1.1) when I click the icon in the launch bar of Wheezy. It says: LXDE-pi I must generate an anomalous device field because they never end. I was just locked out of my firefox sync account because I exceeeded my failed login limit. Just as my blood was beginning to boil (self talk = "you couldn't have made a typo every time, you only have three passwords, one of those has to be right,you can't be THAT stupid...), the reason presents itself: my CapsLock key is now lower-case but the its LED IS ON!
    – user39664
    Mar 28, 2016 at 7:18
  • VIC-20 i really want to help you but you gone from one issue the was regarding by a completely other OS to another issue on a new OS. im not sure if this is conform to the rules... i think you should close this issue and post a new question on the stackexchange or fall back to jessie. Mar 28, 2016 at 18:29
  • OK, sure, I can do that. It never occurred to me that by changing the OS, I was compromising the quality of my question here. Having just re-read this page from the top (and then stopping for moment to think), I've "abstracted" a way to bring to rest all "threads" I wish to say, ask, fix, explain, defend, and release: "to come up with an answer - must first settle on a question" I've just imaged Jessie 2016-03-18 today. Since I have two SD cards "gone back to Wheezy" wasn't really true. But to be useful here, I agree to having a consistent single focus. (ALSOhasMOREstuffCOOL)
    – user39664
    Mar 29, 2016 at 1:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.