I just got Pi Model B. I downloaded Wheezy on SD card and plugged in all of my cords. Everything works fine except the Ethernet port.

The LINK LED flickers for a second while booting up, but then it doesn't do anything and they stay OFF. The browser shows NO CONNECTION.

I checked the cable, and when connected to laptop it shows connections, so the cable is still good.

I tried using 1A and 700mA power supplies as few people had suggested, but it didn't work.

I tried removing USB wireless keyboard / mouse, as it may drain power. Didn't work either. I tried removing HDMI too; it didn't work.

I had ordered 2 units from UK. 1 for me and 1 for my friend. The Unit I gave to my friend is working fine on ArchLinux and everything from SSH is working fine on that.

Can it be hardware problem? If yes can I use any WiFi adapters over USB?

I haven't tried the deep freeze method few suggested (keeping the Pi in fridge for couple of hours seem to make USB / Ethernet work for some folks) but I don't want to do it as it may damage the board.


3 Answers 3


Please show the output of ifconfig -a and dmesg|grep eth0

By the way, it's easy to setup USB WiFi: plug in a compatible adapter, check if you see it as "wlan0" in ifconfig -a output (with HWaddr etc), modify 'wlan0' section in /etc/network/interfaces (assuming you're using WPA/WPA2 password-protected network with DHCP), then reboot:

allow-hotplug wlan0
iface wlan0 inet dhcp
  • Thanks @vk2 :) But finally I got ethernet to work
    – Gaurav
    Jan 15, 2013 at 5:49
  • 1
    +1 for the easy wifi setup- i searched for this before and got really long tutorials installing helpers and junk. lol
    – Piotr Kula
    Jan 17, 2013 at 11:26

I though problem was that I was using a cheaper CAT5 cable, so I changed it with the one that came with my router.

Solution :

And gave a nudge to X1 crystal. And voila ! LINK LEDs lit up like Christmas tree :)

Now Ethernet works with both cables.

Problem (I'm just guessing) :

So I am assuming that there was loose soldering near X1 and it was not oscillating.

  • 7
    Could you please elaborate on "giving a nudge to X1 crystal"? I have the same problem but do not understand what to do at all (electronics noob here ;))
    – severin
    Aug 20, 2013 at 9:27

I had a similar problem, Laptop worked ok when plugged into Ethernet - pi didn't (flashing lights only) using the same cables.

In the end, I opened the Ethernet port (RJ45 socket in the wall) and a couple of the cables were not punched down correctly - punched in, and it is all working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.