I'm having some serious performance issues (i think) using raspbmc to stream videos/music from my windows XP machine.

The setup is as follows:

In the attic : Windows XP P4 3.4Ghz 4Gb ram, edimax wireless PCI card (B/G/N)

In the bedroom : Zoom 3G wireless router (B/G/N) - directly below the XP pc (probably about 2 to 3 metres distance)

In the Living Room : Raspberry Pi (Model B) - TP Link W823N wireless usb device, powered from an externally powered USB hub (about 3- 4 metres distance to the router)

Number of films : 40 Number of audio files : ~4000

The problem Apart from taking ages to scan the music files, very frequently I go to play an audio file, and the time slider is already at a value (say 00:30:22 - 30 seconds in), and refuses to move at all. selecting another music file gives me the same result (time-slider wise, and refusing to play-wise)

Also quite frequently, raspbmc reports that it cannot connect to the SMB server, and hangs.

I do intend to get myself a usb harddrive to store all these on, but in the meantime, i'd like to get SMB working smoother, but i'm not sure if it's an issue with raspbmc or XP.

opening up a Putty Session to the rapsberry Pi, and setting ping running reports an average of 5-6ms response and out of 2,500ish packets 5 were dropped.

occasionally the pings stop when i select a file that doesn't eventually play.

RaspBmc (Nightly build 12/1/2013) running on a samsung 8Gb class 10 card.



I am now trying setting up my win xp machine to server NFS, to see if this gives a performance improvement. I have also swapped the channel of the wireless from 10 to 6, as I believe this is a stronger channel along with 1 and 11.

  • Have you taken a look at /var/log/messages, if anything unusal comes up? I am also using SMB with my Pi, but rather as the server, not the client, and I am getting about 1.2-1.5MB/sec over a 2.4GHz WiFi network.
    – Arne
    Commented Mar 16, 2013 at 20:47
  • Further note: take a look at WiFi quality with iwconfig. Also test network theoughput with netcat or something similar to see if SMB really is the problem. With my setup i also had problems with allocatable memory. A look at /var/log/messages will help, as I noted earlier.
    – Arne
    Commented May 31, 2013 at 6:15

1 Answer 1


Maybe a wireless network isn't suitable here? Have you considered Devolo or alternatives?

--I don't think this is a wireless issue. I am having SMB connection issues with mine and it is hardwired. (running RaspBMC 12.1 with smbclient version 3.6.6)
Can (partially) build the library of movies and then it loses access "Connection Timed Out". Restarted both Windows box and RPi - no help. (My movie directory has 250+ movies) Heard that larger collections mess up SMB but don't know how to fix. I read somewhere that there is a flaw with Samba (specifically 3.6.3) Don't know if newer versions fixed it.

  • What would be the reasons why a wireless network is unsuitable? My two windows laptops and PC both connect without any problem to the router anywhere in the house. For me the issue is defintely the two machines talking wirelessly, but I do see the advantage of using wired for this setup.
    – kolin
    Commented Jan 15, 2013 at 9:49
  • @kolin my suggestion is to move your RPi close to the wireless router and try again. Commented Jan 15, 2013 at 10:55
  • I don't think SMB is the issue here, but the wireless card/drivers. I would switch to ethernet if possible, or at least test your scenario via ethernet.
    – Munkeh
    Commented Feb 14, 2013 at 11:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.