3

I've done a clean install of Raspian Lite on my Rasperry Pi (there is no desktop environment installed). I'd like a kiosk-mode browser running fullscreen without having to worry about maintaining/securing a DE.

After installing Raspbian Lite, I did apt-get install iceweasel and apt-get install x-window-system.

I'm now able to login and run startx iceweasel and I get a functional iceweasel as required; however it's only about a quarter of the screen!

The console that I ran startx from was using the full screen but after launching X/iceweasel the used area got smaller.

Ideally I'd like it to inherit the resolution the console was already using, but I'd settle for having to provide them manually if that's not possible.

1

there are several addons for firefox that give you the features your probably need like fullscreen, no url bar and more...

for example try this addon:

r-kiosk

the browser will start in fullscreen and or without controls you can easily setup the plugin to get use of a bunch of features.

just give it a try.

  • I'll give it a shot tomorrow; however I discovered that by launching this way, menus etc. don't work; so it might be tricky to install! Will post back :) – Danny Tuppeny Mar 28 '16 at 19:09
  • 1
    you can start your desktop in a "normal" way first to setup the browser to fit your needs first. finally when your finish you can go for your way. good luck! – DLLDevStudio Mar 28 '16 at 19:11
  • I didn't install any desktop environment; though I do have normal Raspbian on another SD card, so maybe I can configure it there then copy the home dir over. I'll have a play :) – Danny Tuppeny Mar 28 '16 at 21:00
  • Same issue as with the other answer; doesn't seem to fix the problem :( imgur.com/pp6cxiF – Danny Tuppeny Mar 29 '16 at 18:01
  • hmmm its possible that your screen resolution is not correctly set? looks for me a little like the browser "think" that he run in fullscreen already... what happends if you start it normal and try to resize the window? you can make it more large? – DLLDevStudio Mar 30 '16 at 0:48
1

The way I have set up my Pi to run Iceweasel fullscreen on startup is to use xdotool to simulate the F11 key (fullscreen mode).

Edit ~/.config/lxsession/LXDE-pi/autostart. Mine looks like this:

@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
@xscreensaver -no-splash
@sh /home/pi/start.sh

In start.sh I created a script that launches Iceweasel to a specific URL and switches it to fullscreen by "pressing" F11:

iceweasel https://metrics.librato.com/s/public/mv0aetg14?duration=86400 &
sleep 60
xdotool search --onlyvisible --name iceweasel key F11
  • To avoid sleeps, you can also use the --sync option of xdotool: xdotool search --sync --onlyvisible --name iceweasel key F11 – Chadi Apr 14 at 19:04
0

Install the xul-ext-fullscreen package with apt-get install xul-ext-fullscreen. You might need to activate it once inside Firefox/Iceweasel.

Since the iceweasel respective soon the firefox-esr package is updated to new upstream releases once in a while in Debian and hence also in Raspbian, it might occur that the xul-ext-fullscreen package becomes incompatible with the packaged version of Iceweasel/Firefox. In that case a manually installed extension per user might be the better solution.

It depends a little bit on which version (not variant) of Raspbian you use: Firefox/Iceweasel in Raspbian 7 Wheezy is no more supported, current addons from addons.mozilla.org might no more work with the version available in Raspbian 7 Wheezy. There, the xul-ext-fullscreen package is probably the better solution. On Raspbian 8 Jessie, I suspect that installing an extension inside Firefox is likely the more successful variant.

  • Cool; that sounds like it could be quite simple, I'll take a look at that too. I'm running the latest Raspbian Jessie Light just downloaded yesterday. – Danny Tuppeny Mar 28 '16 at 21:02
  • I installed this, and when I launched iceweasel it asked me to allow the extension install. I agreed and let it restart as required, but the window is still the same size. Here's a pic: imgur.com/pp6cxiF – Danny Tuppeny Mar 29 '16 at 18:00
0

I posted this question on Unix SE too in case it wasn't Pi-specific enough or people there had an idea. There was an answer from Gilles that is the only solution so far I've had work. I'm re-posting it here for others:


taken from https://unix.stackexchange.com/a/272726/84496

Firefox stores the size of the last window in the profile. As of Iceweasel 38, the relevant file is xulstore.json (the size is also recorded in other files but this is the one that matters when launching Firefox unless you're using a session manager extension).

Normally you'll end up with the same window size as the last run. If you need to modify that, edit xulstore.json. The setting is "chrome://browser/content/browser.xul""main-window""width", "height".

  • Iceweasel is a fork from Firefox, I doubt chrome:// is going to work.... – Havnar Mar 30 '16 at 10:53
  • It's the key used in the json file, not a url (I made that mistake - entering it into the address bar actually caused another iceweasel to load inside itself)! Believe it or not, it works. I now have a fullscreen browser. I just need to figure out how to automate this on a clean Pi setup (presumably launch IW to let it create the profile, kill it after a few seconds, then go and modify that file). – Danny Tuppeny Mar 30 '16 at 11:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.