0

I have been working with a Raspberry Pi 2 for little time. I was working with serial devices using webiopi, everything was good and running nicely. However, a few days ago I plugged in the Raspberry, like always, and I tried to run webiopi with the following command:

sudo webiopi -d -c /etc/webiopi/config

After doing that, I got this error:

FileNotFoundError: [Errno 2] No such file or directory: '/dev/ttyACM0'

I don't even know why is looking for that serial device, I'm not using Arduino, I'm using the on-board GPIO.

Do you know how to solve this? I have tried everything I found on the web, but with no results.

  • can you share you /etc/webiopi/config file? Also try using this patch-version RPi-2 : Double-bind – Shan-Desai Mar 29 '16 at 8:55
0

I just found out what was wrong, in my script.py file I was using ttyACM0 instead of ttyAMA0. A dumb mistake I know...

  • Those mistakes are the drive of the human progression. It's the thing we call "learning". And you also practiced a second way to increase our knowledge: you told us about your mistake. I can not understand why someone has downvoted your answer. You saved me hours of blind searching on a similiar mistake. Thank you. I'll upvote your answer to neutralize the downvote. Plz could you mark the answer as the accepted answer. – Peter Paul Kiefer Mar 29 '16 at 15:09
  • I'm glad I saved you those hours, thank you for the upvote. I can mark my answer as correct tomorrow, but I will. – Luz A Mar 29 '16 at 21:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.