Today, after having my Raspberry Pi sitting in a drawer for close to a month, I decided to finally set it up.

Unfortunately, the screen which I bought for it arrived broken, so I am having to do everything through my laptop and Mobaxterm.

When I set up the initial internet connection using an Ethernet cable (I was going to borrow someones, but then I found a humongous purple one from a long time ago), it set up fine.

Unfortunately, it's setting up the Wi-Fi setup which gives me the issue. For what it's worth, my Wi-Fi adapter is an Edimax EW-7811Un.

I tried several methods of setting it up, but none of them have helped.

First, I followed this guide, How-To: Add WiFi to the Raspberry Pi, to set up up using text editing, I triple checked my SSID and password, but to no avail.

Then, I decided to try the Wi-Fi setup offered by Raspberry Pi (because I didn't think of it right away), but it didn't prove useful. Left clicking, it told me that no wireless interfaces were found, and it did not show me my router, right clicking it and clicking Settings did not seem to help either, as SSID did not show my router.

Finally, I finally decided to try this method, Raspberry Pi - Installing the Edimax EW-7811Un USB WiFi Adapter (WiFiPi), but that didn't make any improvements over what I had already.

So as it stands now, this is what I get when I check the wlan0 setup. As you can tell, it does not have an IP address, but a mixture of letters and numbers.

current setup

At this point I'm not really sure what to try next. Suggestions?

  • I struggled via the command line and when i hooked it up via TV, I literally just clicked on Connect to Wifi in the corner and it worked.You might have try this option
    – BantuTech
    Apr 28, 2016 at 13:38

4 Answers 4


This is what I do.

Create a wpa_supplicant file:

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

Add the following to the bottom of the file:


Save, and then make sure the file is readable only by you

sudo chmod go-rwx /etc/wpa_supplicant/wpa_supplicant.conf

Then try and bring your wlan interface down, and back up:

sudo ifdown wlan0

sudo ifup wlan0

Then check if it obtained a wifi address.

Edit: I'm not sure if you'll also need to remove the stuff you put in your interfaces file so it doesn't conflict. If you do, just restore it to its original contents.

  • I guess I'll just reformat the card, write the .img again, then try this. When I try this though, do I have to mention the wpa_supplicant file anywhere, or just create it and fill it out?
    – Frog6666
    Mar 29, 2016 at 3:44
  • No, you don't have to mention it anywhere. But you do need to make sure it is only user readable/writeable. I'll update my answer for completeness.
    – jrel
    Mar 29, 2016 at 3:48
  • The fact that it said 'no wireless interfaces were found' is a bit troubling. Hopefully the adapter hasn't gone bad.
    – jrel
    Mar 29, 2016 at 4:00
  • @Frog6666 - As a sanity check... does the Edimax adapter actually work on a WIndows, or some other, machine? Mar 29, 2016 at 7:42
  • @Greenonline yes it does.
    – Frog6666
    Mar 29, 2016 at 13:08

By following an obsolete tutorial you have broken networking. (Most of this is OK, but DON'T fiddle with /etc/network/interfaces).

See How do I set up networking/WiFi/Static IP for how to fix it.

  • Good news - I rewrote the .img, and now the network detection works. Bad news - even after following the guide, the Wi-Fi connection doesn't seem to be working. I'd disconnect the Ethernet cable, but then I'd lose VNC.
    – Frog6666
    Mar 29, 2016 at 6:32

After reading your clean and very illustrative question. Also I read all the previous answers and I found that none worked for. All the answers are reasonable though. I decided to search about the supported Wi-Fi dongles for RPI. I didn't find yours in the Working USB Wi-Fi section.

This link provides you with all possible working USB Wi-Fi adapters. It's actually a good resource to search for info at. Besides, this link shows some dongles tests, you can also check it.

So my main suspect is the dongle itself :D. Try using another one from your friends first before buying a new one if this answer helps.

Btw your dongle should be supported as it's listed, but it's listed in the Problem USB Wi-Fi Adapter section.

Hope I helped.


Just going into Menu>Setting>WiFi Configuration and setting it up worked for me, I did nothing else.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.