1

A week or so ago I updated (sudo apt-get update && sudo apt-get upgrade) two Raspberry Pi 2s after a few weeks since the last time I had done so. As I normally do at this opportunity, I rebooted them.

I have a few services that (up until now) start on boot; BitTorrent Sync, OMSAgent and my own custom Upstart script for AutoSSH. Since that update - with some random chance that I can't detect - some of these services don't start on their own.

I don't seem to be able to see anything in /var/log/syslog nor /var/log/messages but I've only recently begun to get a grip of syslogging in Linux, so may be looking in the wrong place for service starts/failures.

The only thing that seems to be erroring is ntpd

Mar 29 22:10:01 hostname ntpdate[424]: step-systime: Invalid argument
Mar 29 22:10:01 hostname ifplugd(eth0)[287]: Program executed successfully.
Mar 29 22:10:50 hostname ntpdate[1295]: step time server 131.188.3.220 offset 39.486146 sec
Mar 29 22:10:54 hostname ntpd[1354]: ntpd [email protected] Mon Nov  2 04:29:31 UTC 2015 (1)
Mar 29 22:10:54 hostname ntpd[1355]: proto: precision = 1.250 usec
Mar 29 22:10:54 hostname ntpd[1355]: Listen and drop on 0 v4wildcard 0.0.0.0 UDP 123
Mar 29 22:10:54 hostname ntpd[1355]: Listen normally on 1 lo 127.0.0.1 UDP 123
Mar 29 22:10:54 hostname ntpd[1355]: Listen normally on 2 eth0 192.168.254.50 UDP 123
Mar 29 22:10:54 hostname ntpd[1355]: peers refreshed
Mar 29 22:10:54 hostname ntpd[1355]: Listening on routing socket on fd #19 for interface updates
Mar 29 22:10:54 hostname ntpd[1355]: restrict: error in address '::' on line 38. Ignoring...
Mar 29 22:10:54 hostname ntpd[1355]: restrict: error in address '::1' on line 42. Ignoring...

Info:

user@hostname ~ $ cat /etc/*-release
PRETTY_NAME="Raspbian GNU/Linux 7 (wheezy)"
NAME="Raspbian GNU/Linux"
VERSION_ID="7"
VERSION="7 (wheezy)"
ID=raspbian
ID_LIKE=debian
ANSI_COLOR="1;31"
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
user@hostname ~ $ uname -a
Linux hostname 4.1.13-v7+ #826 SMP PREEMPT Fri Nov 13 20:19:03 GMT 2015 armv7l GNU/Linux

EDIT 2016-03-29 22:59 BST:

Posting ntp.conf:

pi@lon-rpi-stash ~ $ cat /etc/ntp.conf
# /etc/ntp.conf, configuration for ntpd; see ntp.conf(5) for help

driftfile /var/lib/ntp/ntp.drift


# Enable this if you want statistics to be logged.
#statsdir /var/log/ntpstats/

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable


# You do need to talk to an NTP server or two (or three).
#server ntp.your-provider.example

# pool.ntp.org maps to about 1000 low-stratum NTP servers.  Your server will
# pick a different set every time it starts up.  Please consider joining the
# pool: <http://www.pool.ntp.org/join.html>
server 0.debian.pool.ntp.org iburst
server 1.debian.pool.ntp.org iburst
server 2.debian.pool.ntp.org iburst
server 3.debian.pool.ntp.org iburst


# Access control configuration; see /usr/share/doc/ntp-doc/html/accopt.html for
# details.  The web page <http://support.ntp.org/bin/view/Support/AccessRestrictions>
# might also be helpful.
#
# Note that "restrict" applies to both servers and clients, so a configuration
# that might be intended to block requests from certain clients could also end
# up blocking replies from your own upstream servers.

# By default, exchange time with everybody, but don't allow configuration.
restrict -4 default kod notrap nomodify nopeer noquery
restrict -6 default kod notrap nomodify nopeer noquery

# Local users may interrogate the ntp server more closely.
restrict 127.0.0.1
restrict ::1

# Clients from this (example!) subnet have unlimited access, but only if
# cryptographically authenticated.
#restrict 192.168.123.0 mask 255.255.255.0 notrust


# If you want to provide time to your local subnet, change the next line.
# (Again, the address is an example only.)
#broadcast 192.168.123.255

# If you want to listen to time broadcasts on your local subnet, de-comment the
# next lines.  Please do this only if you trust everybody on the network!
#disable auth
#broadcastclient

EDIT 2016-04-05 00:27 BST:

Is there any chance that this behaviour is because I'm running Upstart on these RPis on Raspbian Wheezy? And I'm just seeing a quirk/bug in the behaviour? (it should be noted that only my custom AutoSSH wrapper is written using Upstart conf, the rest are standard init.d scripts)

2
  • Please post your ntpd config file as well.
    – Will
    Mar 29, 2016 at 21:50
  • @Will I've never modified it; so it should be default. Updating question now...
    – Ashley
    Mar 29, 2016 at 21:58

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.