0

I had a working PiTft - by working I mean that it would boot up - but then I updated (big mistake). I had to re-burn the distro to an SD-card.

I switched between Wheezy and Jessie, but now it won't even boot up on the PiTft. I'm getting really ticked about this at the moment as this was a present so I could use my pi while my family watches TV.

I took the time to format the SD-card, and even zero it. Nothing is working. Please help. (I ran the easy install method every time so it should be working.)

I tried to google this problem and got nothing based on my problems. The answers that adafruit provided did not help at all, and the screen starts up as white and stays white.

1

The Adafruit PiTFT needs a customized kernel and special settings to work. Unfortunately system updates can overwrite those.

I have updated the kernel for use on Raspberry Pi, Pi 2 & Pi 3, and created a package that installs it. You can install that package and run the Adafrui-Helper to set up your screen again.

You can find a step by step instruction on the "Sticky Finger's Kali-Pi" site:

http://whitedome.com.au/re4son/sticky-fingers-kali-pi/#PiTFT

The guide is for kali but can be applied to any other debian based installation.

Hope that helps, Re4son

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.