0

Unfortunately there's little support for MOSH and I have no idea what I'm doing. I installed MOSH on my Macbook and my Raspi Pi. I tried 'mosh root@192.168.0.9' and it seems to work but then the splash screen appears only for a fraction of a second and says something about port 60002 (it is impossible to read the error message). How to use MOSH and what am I doing wrong? I've tried Juice SSH as well and it didn't work either. Any ideas?

  • What was wrong with the mac terminal and SSH? The combination of "little support and no idea what your doing" does not seem like a easy path to success. – Steve Robillard Apr 2 '16 at 19:39
  • Thanks Steve, good point. Firstly, I don't know if I need to start a server or client on any sides. I started the connection from my Mac but the target machine (Pi) refuses every time. Again, I cannot read the error why the connection was refused, it was something like 'port 60002'. Needless to say, I've tried connecting on port 60002 with no success. There are no tutorials on using MOSH so I'm just guessing stuff. – alkopop79 Apr 2 '16 at 19:59
  • What are you trying to accomplish (beyond run MOSH shell). Why are you choosing to use MOSH? Have you tried simple SSH? What do you need that SSH does not provide? what happens if you do the following from mac terminal ssh pi@yourpisip? – Steve Robillard Apr 2 '16 at 20:02
  • I just want to try it and use it on my mobile. SSH works perfectly and I can't see the reason why MOSH wouldn't... What I don't get is that the MOSH application seems to work on both sides, it's just I cannot login. I wish there was a tutorial... – alkopop79 Apr 3 '16 at 18:23
1

Problem solved: I added the line 'port 60002' in etc/ssh/sshd_config and MOSH shell works perfectly ever since.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.