0

I got my Raspberry Pi 3 Model B shipped recently. As I don't have any HDMI display, I ran to my neighbor's house to test my Pi. I used the memory card provided with the kit which had NOOBS preinstalled. I installed Raspbian and it worked like a charm.

Back at my house, I was trying to use my laptop's screen as display for my Pi and I came across a tutorial here- https://pihw.wordpress.com/guides/direct-network-connection/comment-page-4/#comment-7373

In the tutorial it's told to edit the cmdline.txt file in the Boot section and add a line ip=<ip addresshere> and save it as cmdline.direct, then copy the original file and save as cmdline.normal, and then swap between the files. So I made the required edit and swapped the cmdline.direct with cmdline.txt (yes I did change the name), and I made the changes in Kali, as in Windows you can't really see the boot partition when using NOOBS. When I connected it to my lappy running Kali and tried ssh @169.254.0.2 I got an error saying that Destination Host is unreachable. When I try to ping the ip I get the same error.

I tried it on my Windows laptop with puTTY. All I got was a blank console screen which gave the very same error after a while.

What am I doing wrong? I really need to get my Pi working on my laptop. Both My Windows and Kali PCs are set to obtain IP's automatically.

Any help will be greatly appreciated. Thanks.

EDIT: I solved the problem for puTTY on Windows. I went to my neighbor's house and used his TV as HDMI output for my Pi and followed the tutorial, this time using the steps that were for when you have an HDMI output. The first step was to run the hostname -I command which wasn't supposed to return anything, but in my case, returned an IP address. I immediately tried pinging that IP from my Windows PC and I could ping it. I then tried puTTY which gave me access to the Pi's terminal. Seems like the Pi is intelligent enough to assign itself a static IP. However I can still neither ping the same IP from Kali nor connect to it. Any idea why?

  • If you want any answer you should really paste into your question what you ACTUALLY did. We have no idea except it won't work. – Milliways Apr 5 '16 at 23:43
0

The Foundation recommends "Beginners should start with NOOBS". This is marginally easier to setup (if you have all the prerequisites) and requires no additional program, but then problems start.

NOOBS seems to have problems with networking and is difficult to update.

To make matters worse the experienced users on this site do not use NOOBS, and have installed Raspbian (or other distribution) directly and are unable to help with problems NOOBS users have.

The vast bulk of the tutorials on the Web assume you are running Raspbian and describe files which do not exist on NOOBS (or are in different locations which are inaccessible on Windows or OS X).

Indeed the tutorial you referenced specifically states "These instructions are only applicable to manually installed installations (i.e. those which are imaged directly using SDimager rather than using NOOBS."

If you install Raspbian (or your chosen distribution) directly you will get more help.

  • Yeah but I got around the NOOBS problem by accessing the memory card through Kali... Which gave me access to the cmdline.txt file and I made the required changes. And it is clearly stated in the tutorial that if Installed from NOOBS use any distro of Linux to access the boot partition. Anyways , Raspbian is a 1.3 GB download that I'd like to avoid, but still if its necessary, I'll do it. Therefore shall I download it or I'm better off using Kali? – YaddyVirus Apr 5 '16 at 5:37
  • @YaddyVirus I don't know Kali and can't comment (or make other than general observations about Linux). The tutorial IMO contains a number of other shortcomings (apart from being long and difficult to read). You should really paste into your question what you ACTUALLY did, not expect people to guess. I find the reference to the 169. address range strange. This is a link-local address and is not routable. – Milliways Apr 5 '16 at 6:01
  • Well I all I did was assigned the Pi a static IP by editing the cmdline.txt file. It ought to run the ssh but it didn't. The destination host is unreachable, is the error I get. Well I think of trying the 198. address range now... I'll post back the results. – YaddyVirus Apr 5 '16 at 10:14
  • please read the edit – YaddyVirus Apr 5 '16 at 17:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.