2

tl;dr: During boot my one-year-old Raspberry Pi 2 stops with the rainbow color screen of death. Power supply, SD card, OS on the SD card, and "boot_delay=1" are OK, but did not help.

Origin of the problem: After some unplanned switch-offs without shutdown command, the micro SD card has died. My Mac could not recognize the SD card any more, and it became very hot when I put in the Mac.

Solution I've tried: I tried to use a new SD card with the latest NOOBS and/or Raspbian (release date 2016-03-18). Even with the "boot_delay=1" from http://elinux.org/R-Pi_Troubleshooting#Coloured_splash_screen. But the Pi stuck during boot with the rainbow color screen.

I've checked:

  • Power supply is ok. (I've bought it specially for Raspberry Pi-s. It works with my new Pi 3 and Pi Zero. I tried a special one with 5A as well.)
  • SD card is ok. (I've tried three different ones. All of them works perfectly.)
  • SD card's preparation for OS is ok. (I've followed the guide from raspberrypi.org for Mac OS X. I've tried both NOOBS (copying) and image files (dd). The prepared SD cards (three of them) work perfectly with my new Pi 3 and Pi Zero.)
  • The socket of the micro SD card seems to be fine, but I could not test electronically.

Can you help me to find any solution? Thank you for all your help.

  • 1
    Do you have another RPi to check your new installed SD's ? If you have check it because i think (guess) your RPi is dead also :/ – ahmetertem Apr 5 '16 at 3:52
  • I have a new RPi3 and RPiZero. With both of these the newly prepared SD-s are working. (Even though once I installed and set up everything during the first boot the SD from RPi3 is not working in the RPiZero. But it is an understandable compatibility issue.) New SD-s are working in both, but not in the old RPi2. – borazslo Apr 5 '16 at 4:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.