3

I'm having a hard time getting my Pi to automatically login using the standard pi/raspberry user and pass. I have a script that runs and works great but needs to be logged in to run.

I did some searching and can only find guides using inittab which apparently doesn't work anymore? My inittab file is empty and I've been told not to use this method.

Anyone have any other suggestions they know will work? Just looking to automatically log my Pi in on boot using pi/raspberry.

Thank you!

4
  • 3
    Just to be sure: did you check raspi-config ?
    – ahmetertem
    Apr 5, 2016 at 19:08
  • 1
    I had a similar problem, trying to auto-login another user. Inittab is not working for me either.
    – NULL
    Apr 5, 2016 at 19:11
  • I did try the raspi-config which didn't seem to work. On sudo-reboot things seem okay but when I physically unplug/plug back in things get screwed up.
    – Sharks
    Apr 5, 2016 at 19:14
  • 1
    FYI: unplugging without safe shutdown is not safe for device and OS
    – ahmetertem
    Apr 5, 2016 at 20:02

3 Answers 3

1

If you are using the latest Raspbian Jessie Image then you should by default boot to X.

If you are using older distribution then you can manually Enable Boot to Desktop/Scratch/Command-line using sudo raspi-config utility.

enter image description here

0

Run sudo raspi-config, go to boot options select option 1

-1

Just for being an answer;

If you need auto-login or not auto, you need to type raspi-config to terminal (if in dos view you may use too) and choose Enable Boot to Desktop/Scratch. Choose your option and save, it'll ask Reboot or not, then reboot it.

Regards

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.