0

After installing adafruit-webide I realized the server autostarts at boot.
I tried to prevent the service from autostarting to no avail

I tried all of these:

sudo update-rc.d -f adafruit-webide.sh remove
echo manual | sudo tee /etc/init/adafruit-webide.sh.override
sudo update-rc.d adafruit-webide.sh disable

always

sudo service --status-all

shows the service running (and I can enter the ide in my browser).

Even

sudo service adafruit-webide.sh stop

is not stopping the service.

I must be doing something really wrong.
I am running and up-to-date raspbian on a rasbberry pi 3.
I do not want to remove the program I just want to start/stop the service when required.

EDIT
I tried systemd commands like

sudo systemctl disable adafruit-webide.service

to no avail. Service is always on after reboot.

And there is something more interesting: when using sudo service adafruit-webide stop, I can see it actually stopping but, after few seconds, it restarts again:

automatic restart after stop

0

The solution that worked is marking the service as unstartable with

sudo systemctl mask adafruit-webide.service

systemctl stop/disable did not work for some reason.
systemctl mask is a more aggresive mode of stopping the service.
It links the unit to /dev/null making the service un-startable either manually or automatically unless it is unmasked again.

There are interesting references here, here (both from fedora) and here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.