3

I have installed BerryBoot on a microSD card which I use with a Raspberry Pi 3. On this card, I now have a quadruple boot: Raspbian, UbuntuMATE, OpenELEC and Retropie. I am able to launch all operating systems fine by using a keyboard, a mouse and a screen connected directly to the Pi.

Now I want to transfer files from the house main computer (running under Ubuntu 14.04) to RetroPi. I would like to do the transfer through Nautilus since this interface is more user-friendly than using the console.

I boot the Pi and start RetroPi. I am able to ssh from Ubuntu to Retropi using the console. But when I type the following line from the Nautilus menu (Go -> Enter Location):

sftp://192.168.1.3

I get the following error message:

Oops! Something went wrong. Don't have permission to access the requested location.

Any idea why I am getting this error message ? Are there different parameters to allow SSH (working) and SFTP (not working) access on RetroPi ?

Additional Information

1) I get the same error when I try to SFTP into UbuntuMATE.

2) I get the same error when I specity the user name on the Pi:

sftp://pi@192.168.1.3

3) Here is some information I get from running sftp in the terminal:

phodor@UBUNTU: sftp -vvv pi@192.168.1.3
OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to 192.168.1.3 [192.168.1.3] port 22.
debug1: connect to address 192.168.1.3 port 22: Connection refused
ssh: connect to host 192.168.1.3 port 22: Connection refused
Couldn't read packet: Connection reset by peer
  • are you able to sftp from comandline? sftp 192.168.1.3? – Jakuje Apr 9 '16 at 12:58
  • @Jakuje. Apparently I cannot sftp from the command line. See updated post above. Yet I was able to transfer files using scp. – phodor Apr 9 '16 at 14:38
  • How are you "able to ssh from Ubuntu to Retropi using the console."? – Jakuje Apr 9 '16 at 14:38
  • @Jakuje: the following works fine: sudo ssh pi@192.168.1.3 – phodor Apr 9 '16 at 14:50
  • And sudo sftp pi@192.168.1.3 works also? How do you have the pi connected to your computer? – Jakuje Apr 9 '16 at 14:52
1

I was able to solve the problem. It turns out there was a key mismatch when doing the ssh between my Ubuntu computer and RetroPie. The IP mismatch was probably caused when I restarted my Pi. I guess IP 192.168.1.3 had been re-associated to OpenELEC or UbuntuMATE. Nautilus was not providing me with any information about this.

When trying to run ssh again in the terminal, I got a new warning and the terminal suggested to run the following command to reset my keys, which solved the issue:

sudo ssh-keygen -f "/root/.ssh/known_hosts" -R 192.168.1.3

I guess the next step will be to ask static IPs for each Virtual machine on my Pi 3:

Raspbian -> 192.168.1.101
UbuntuMATE -> 192.168.1.102
OpenELEC -> 192.168.1.103
RetroPie -> 192.168.1.104

Thanks to all who answered: your comments led me to the solution !

  • I have been using "scp" to copy files. I'll give "sftp" a try. Thanks – PaulF8080 Apr 22 '17 at 18:48
0

You probably need to specify user to the Nautilus. Something like

sftp://pi@192.168.1.3

should do the job. But also verify if it works from command-line:

sftp pi@192.168.1.3

If not, add some verbosity to the output: -vvv switches to sftp will tell you more. See my other AskUbuntu answer.

  • I still get the same errors unfortunately... I updated my post with the output from the -vvv verbose option. – phodor Apr 9 '16 at 14:37
0

You must enable ssh on retro-pi configuration (interface menu).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.