I have connected laptop and Raspberry pi 3 to one Wifi router. But I can't connect to Raspberry via SSH from my laptop. On raspberry SSH is enabled and I can connect to it from Raspberry itself. Here are some settings I have:

sudo service ssh status >>>>>>
ssh.serice - OpenBSD Secure Shell server
Active: active (running)
raspberrypi systemd[1]: Started OpenBSD Secure Shell server
raspberrypi sshd[503]: Server listeting on port 22
raspberrypi sshd[503]: Server listeting on :: port 22


auto lo
iface lo inet loopback
iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

ifconfig info
wlan0   inet addr: Bcast: Mask

I tried to connect on ubuntu like this:

ssh [email protected]

And on windows via Putty

  • Are you using PuTTy? Have you checked the IP address for you Pi is correct?
    – Darth Vader
    Commented Apr 9, 2016 at 12:16
  • I've tried on ubuntu and on windows - same effect, just didn't connect
    – lomboboo
    Commented Apr 9, 2016 at 12:20
  • I've edited question with ifconfig info
    – lomboboo
    Commented Apr 9, 2016 at 12:21
  • 1
    "just didn't connect" -> Can mean a few different things although the most likely one here is the node does not exist/is not visible. You said you'ved "edited question with ifconfig info", but you didn't; just edit in the output of ip addr instead. Then explain exactly how you are trying to connect from elsewhere and exactly what message you received, because I know it wasn't "just can't connect".
    – goldilocks
    Commented Apr 9, 2016 at 12:31
  • Does 'putty' hang or quit immediately ? If it hangs - maybe you have a firewall getting in the way ? Can you ping the pi from the same host ok ?
    – monojohnny
    Commented Apr 9, 2016 at 17:02

2 Answers 2


You appear to be attempting to set static IP address in /etc/network/interfaces. This will not work. See the following tutorial

How do I set up networking/WiFi/Static IP

EDIT I may be misinterpreting what you have in /etc/network/interfaces. As posted this implies that you have added wlan0 inet addr: Bcast: Mask

In addition will not work through a router. This is a link-local address and is not routable.

If you have not entered this it implies that DHCP has not assigned an IP address.


Have you checked the setting of your WLAN Box? There must be a checkbox down in the menu. It must be activated so that your computers can "talk" directly to each other in your WLAN net.

Hope I could help you.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.