0

I'm not sure whether I've seen mention of this here before or not.

Anyway, I have a B+ with max_usb_current=1 enabled so I can run an external USB drive off it. There's never been a problem with this, but usually the pi is plugged into a dedicated 2+ amp adapter.

Just now I had it instead running off a 3.8 A powered hub, which I think is unregulated. Anyway, I plugged in the HD and suddenly the red PWR led started blinking steadily, about 1 Hz.

The pi itself remained operating and responsive and the blinking stopped when I unplugged the HD. I shut the pi down, plugged it in with a dedicated adapter, and put the HD back in, everything is fine.

Is this a documented/recognized feature of the (some of the) newer (+ and beyond) models?

  • 1
    I have seen the same behavior with model 2's – Steve Robillard Apr 10 '16 at 18:32
  • I experienced something similar with my Pi3. I expected to have no problems with a 2A supply, but tracked it down to the cable. There doesn't seem to be any supply of good microUSB cables so I made my own. Incidentally the APX803 is 4.63±0.07V so even if the LED is on the supply can be below minimum 4.75V. – Milliways Apr 11 '16 at 0:33
  • Actually the "dedicated adapter" is a 2.1 A USB charger using the exact same cable, so in this case I can't blame that; obviously the hub won't put out the ~1 A I'd guess it takes to run the pi with a drive attached. – goldilocks Apr 13 '16 at 11:51
3

It sounds like the power supply is failing to regulate and dropping out momentarily. The answer below seems to describe a similar scenario and the rpi wiki also mentions that the blinking PWR LED indicates an issue with the power supply.

From this question:

I have a Raspberry Pi B+ connected to an external USB disk, a Seagate Portable 1 Tb (no external power source)

...

The red light blinking but everything working fine

The accepted answer by user @tslmy who quotes the wiki at http://elinux.org:

Red power LED is blinking

A blinking red power LED indicates problems with the power supply. On model A and B, it is hard-wired to the 3.3V power supply rail. If it is blinking, as one user has reported1 it means the 5V power supply is dropping out. Use a different power supply.

On model B+ (and presumably also the A+), the circuit has been improved to give a much more reliable warning of poor power quality. The red power LED is wired to an APX803 supervisor[2] which kicks in when the 5V power supply drops below 4.63V[3]. If it does, the LED will blink. Check your connections, cable, and power supply.

From the APX803 supervisor data-sheet:

Microprocessors (μPs) and microcontrollers (μC) have a reset input to ensure that it starts up in a known state. The APX803/D drive the μP’s reset input to prevent code-execution errors during power-up, power-down, or brownout conditions. They assert a reset signal whenever the VCC supply voltage declines below a preset threshold and keep it asserted for a fixed period of time after VCC has risen above the reset threshold

If the data-sheet for the model B+ is correct, the APX803 is hooked up to the red PWR LED as the wiki states. I can't account for the blinking (could it be caused by C6? Is it actually the raw input power drops you're seeing? Is it a feature of the APX803?) but it certainly shows that the APX803 can make or break the ground connection of D1 (red LED) via Q1 (depletion-mode n-channel MOSFET):

Raspberry Pi Model B+ APX803 brown-out detection circuit

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.