I have a normal usb 2.0 cam. Connecting it to my pc, it works perfectly. It is not working with my raspberry pi (2). I had installed motion and it had worked good before 2/3 weeks when I tried it but now, it says

[1] Retrying until successful connection with camera

[1] Failed to open video device /dev/video0: No such file or directory

When I run:

sudo modprobe bcm2835-v4l2 It gives me:

ERROR: could not insert 'bcm2835_v4l2': Operation not permitted

I searched up much but did not find a solution. When I run:

vcgencmd get_camera

I get:

supported=1, detected=0

What can I do?


Problem Solved!!

What I did was:

1) Removed Motion from Raspberry Pi using

sudo apt-get --purge remove motion

2) Disabled Raspberry Pi Camera in raspi-config and rebooted the Pi

3) Installed fswebcam using

sudo apt-get install fswebcam

4) Tried capturing a photo with it using

fswebcam -r 640x480 --no-banner image3.jpg

5) It worked!! Then Installed Motion and tried streaming it and that also worked!!

This is the solution...

  • I am stuck at your point 4. When I enter that command I get a no such file or directory error for /dev/video0. I am running on a raspberry pi zero with raspbian. Running "sudo modprobe bcm2835-v4l2" does not output anything
    – JRsz
    Jun 14 '18 at 0:39
  • @JRsz Did u try reinstalling motion? Starting from the first step? Make sure you reboot your Pi before installing it again. It worked for me! I was stuck at "no such file or directory" for a couple of weeks! This did work for me... Try reinstalling Raspbian if nothing works Aug 13 '18 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.