2

I'm trying to port a buildroot build for Pi2 to Pi3. I got the build to boot cleanly by adding the 2710 DTB, but I cannot seem to get the built-in wifi going.

I'm attempting to build with the kernel from github.com/raspberrypi (@b698f50 / 4.1.y branch) and rpi-firmware (@efdcf16 right now, though I've tried a few different versions with same results).

I've tried with both the stripped down version of bcm2709_defconfig that I was using earlier, and the stock defconfig from the Raspberry Pi kernel source.

The wireless does not appear in the list of network interfaces. The brcmfmac driver is compiled into the kernel instead of a separate module (although I've previously also tried keeping it as a separate module and modprobing manually). All the firmware files that I believe are related are supposedly there:

$ ls /lib/firmware/brcm/
bcm4329-fullmac-4.bin      brcmfmac4329-sdio.bin      brcmfmac4350-pcie.bin
bcm43xx-0.fw               brcmfmac4330-sdio.bin      brcmfmac4354-sdio.bin
bcm43xx_hdr-0.fw           brcmfmac4334-sdio.bin      brcmfmac4356-pcie.bin
brcmfmac43143-sdio.bin     brcmfmac43340-sdio.bin     brcmfmac43569.bin
brcmfmac43143.bin          brcmfmac4335-sdio.bin      brcmfmac43570-pcie.bin
brcmfmac43236b.bin         brcmfmac43362-sdio.bin     brcmfmac43602-pcie.ap.bin
brcmfmac43241b0-sdio.bin   brcmfmac4339-sdio.bin      brcmfmac43602-pcie.bin
brcmfmac43241b4-sdio.bin   brcmfmac43430-sdio.bin     brcmfmac4371-pcie.bin
brcmfmac43241b5-sdio.bin   brcmfmac43430-sdio.txt
brcmfmac43242a.bin         brcmfmac43455-sdio.bin

dmesg does not show absolutely any activity related to wireless devices.

What can I do to find out why the device is not appearing? Or do you have any suggestion on what to try next?

4

A little late but might help someone in the future. I had the same problem, couldn't get it to load the driver but turned out you had to set /dev management under "System configuration" to "Dynamic using devtmpfs + mdev" in order to get it to detect the device and load the module.

I have put together a small Raspberry Pi 3 buildroot config which enables both the built in wifi and bluetooth chip:

https://github.com/danielnilsson9/buildroot-rpi3

0

In my particular case, this was happening because the Pi3 boot loader wants a kernel that has something called a 'trailer'. This trailer thing also works on Pi2 (with correct firmware, I imagine). The trailer is added using a script that comes bundled with the RPi kernel, and you can get a kernel image with a trailer by following the official Kernel Building tutorial:

sudo scripts/mkknlimg arch/arm/boot/zImage /boot/$KERNEL.img

Without this trailer, the kernel is booted without device tree support, and this leads to various devices, including the wifi/bt radio becoming unavailable even though drivers and firmware are there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.