4

So I have this problem.

I got a raspberry Pi 3 recently, and put NOOBS on a 16gb sd card. I stick the card into pi and the system installs as normal, boots into raspbian, i can connect to internet and do all that, basically it works.

But then when I turn off the pi either by just clicking shutdown or using command 'sudo shutdown' in terminal, it fails to boot second time. On the boot log there are two fail messages:

[FAILED] Failed to start Load/Save Random Seed
...
[FAILED] Failed to start Update UTMP about System Boot/Shutdown
[DEPEND] Dependency failed for Update UTMP about System Runlevel Changes

As a result, raspbian doesn't boot into the desktop with apps etc, but just gives me a console prompt so I can still see files and directories, etc. but I can't use it as during a first boot. I have tried to reinstall raspbian a few times, I once managed to boot it on the second try, it showed the desktop etc, but instead of letters there were just rectangles (so i couldn't even type anything). I am so confused and annoyed, might that be issue of the sd card or the raspberry pi itself?

Any assistance would be much appreciated. Cheers

  • What about the third time, does it boot normally then? – Dmitry Grigoryev Nov 21 '16 at 9:52
2

When you boot and it goes into the command line, use the command

startx

This will start the GUI. Once this is done, check the

raspi-config

file settings and go on the boot_behavior option, set it to automatically boot into the GUI.

Hope this is of help.

  • It did the trick! Thanks a lot! Edit: in fact it did not. It goes past the log stage but then just a black screen with mouse pointer appears but it doesn't progress further:( – user44887 Apr 13 '16 at 14:59
  • Try powering the Pi on whilst holding the shift key – BantuTech Apr 13 '16 at 15:13
  • Did you manage to get past this? – BantuTech Apr 14 '16 at 22:16
0

I ran into similar problem, here is my solution for your reference.

  1. Make sure that the OS works well in command line, the only problem is that the X Windows failed to load at boot up, or when initiated in command line by sudo startx or sudo init 5.

  2. It's very likely that packages installed by apt-get upgrade conflict with X Windows. So check the apt upgrade log for suspicious packages. One quick way is using grep -A 2 "2016-04-15" /var/log/apt/history.log, where "2016-04-15" is when upgrade started.

  3. The problem got solved after uninstalling the following three packages, the command is sudo apt-get remove --purge <package-name>.

    Start-Date: 2016-04-15  11:39:17
    Commandline: apt-get dist-upgrade
    Install: pypy:armhf (4.0.1+dfsg-1+rpi1), pypy-lib:armhf (4.0.1+dfsg-1+rpi1, automatic), pishutdown:armhf (0.1, automatic)
    --
    End-Date: 2016-04-15  11:42:41
    
  4. Here is a nice article on apt upgrade and restore.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.