0


This happens to me every time:

I prepare a fresh microSD card on my Mac, put it inside my Raspberry Pi 2.
It boots fine.
I shut it down and boot again (or Reboot).
It fails with a Kernel Panic.

Why and how can I avoid it??
It happened to me both with the latest Raspbian version and also with Retropie.
And it keeps happening every single time, even if I just boot with a screen and LAN connected.
If I boot without screen and just LAN, it's the same thing. I can SSH into it and after the first reboot it's gone.

SD Card: Toshiba SDXC 64GB (new)
OS: Raspbian Jessie, Retropie v3.6
Pi model: Raspberry Pi 2

error message
Update:
I ordered 2 SanDisk Ultra's with 16GB each, I will inform you as soon as I'll get them. But I am pretty sure it was the card which was bad. (64GB, SDXC, Toshiba - 3 negatively influencing factors lol)


Update 2:
See my answer: The SanDisk Ultra works perfectly, so it really was the card that just DOESN'T WORK - DON'T BUY A TOSHIBA SDXC FOR A PI! :-)


- solved :) -

  • 3
    Could you edit your post and include a photo of the kernel panic messages? – joan Apr 15 '16 at 14:38
  • How are you poewering the Pi? Have you tried a new SD card? How are you shutting down the Pi? – Steve Robillard Apr 15 '16 at 15:48
  • 1
    Could be a problem with the SD card – Darth Vader Apr 15 '16 at 16:35
  • @steve-robillard I am powering it through an iPhone 6 wall adapter. It should provide enough power I think.. (?) I am shutting it down via "sudo shutdown -h now". Okay I will return the SD card tomorrow.... It's an SDXC 64 GB Toshiba card. – unixb0y Apr 15 '16 at 22:38
  • I would check the verified SD card list elinux.org/RPi_SD_cards. While some 64GbB cards work the foundation has not suggested anything bigger than 32GB. – Steve Robillard Apr 15 '16 at 23:11
1

UPDATE / SOLUTION:
So, I got 2 SanDisk Ultra's with 16GB each in the mail today. Thank you all again for your answers. It was clear to me that somehow, my Pi seemed to destroy the file system on the 64GB Toshiba card (or it destroyed itself?? 🤔), but as I couldn't figure out what it was, I tried to return the card and changed it for 2x16GB (yes I know that's only 32gb @ the same price but I don't care :D).

So, I flashed the cards with different images and both cards work like a charm and - most importantly because this was the problem - survive all the reboots that I need to do :) (remember with the other card, it got stuck at the 1. Reboot / 2. Boot).

I can really recommend the SanDisk Ultra MicroSD! (~8€ for 16GB)
For anyone using a mac: "PiFiller" - a small AppleScript App - provides a quick and easy way to flash (micro)SD cards for raspberrys :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.