2

The icon in the tray does not show any wireless interfaces when I click on it. I know my adapter SHOULD work (Tenda W522U), but it does not appear to. I am running Raspbian Jessie. The output of commands is listed below.

lsusb

...
Bus 001 Device 004: ID 148f:3572 Ralink Technology, Corp. RT3572 Wireless Adapter
...

lsmod

...
rt2800usb   17802  0
rt2800lib   71907  1 rt2800usb
rt2x00usb    8553  1 rt2800usb
rt2x00lib   36744  3 rt2x00usb,rt2800lib,rt2800usb
mac80211   542174  3 rt2x00lib,rt2x00usb,rt2800lib
cfg80211   420690  2 mac80211,rt2x00lib
crc_ccitt    1161  1 rt2800lib
rfkill      16659  1 cfg80211
...

/etc/network/interfaces

auto lo
iface lo inet loopback

iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

iface default inet dhcp

/etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
  • try running the command sudo ifconfig wlan0 up – Kenneth Spear Apr 15 '16 at 19:35
  • Still nothing. No output in the terminal, either. – smithb99 Apr 15 '16 at 19:37
  • have you tried to set a static IP? Don't do that yet if you haven't. – Kenneth Spear Apr 15 '16 at 19:38
  • I have before. It worked on Raspbian Wheezy over Ethernet. – smithb99 Apr 15 '16 at 19:42
  • Try rebooting and leave the wireless adapter plugged in. Then try ifconfig wlan0 up without an ethernet plugged in – Kenneth Spear Apr 15 '16 at 19:44
5

I just struggled with the same problem. I noticed that if I ran ifconfig wlan0 would show up but I would only have an ipv6 adress, the other one was completely gone.

I read that in the release of Raspian Jessie the way you have to configure wifi changed. Instead of setting up my static ip adress in /etc/network/interfaces I put them in /etc/dhcpcd.conf

To configure my static ip I added the following lines at the end of the file. (Of course you have to replace the stuff with what's applicable to your network settings)

interface wlan0
static ip_address=192.168.xx.x/24
static routers=192.168.xx.x
static domain_name_servers=8.8.8.8 #DNS server of google 

I read it here (my source is dutch though)

  • 1
    I was having same problem due to a someone who made a change in the /etc/network/interfaces file and then did not back the change back out. The result of the entry caused the same error as the OP as I think my PI 3 was looking for a specific SSID rather than the auto functionality. I was at a loss until I found this question and answer which told me which file to look at. Thank you so much. – Richard Chambers Oct 30 '17 at 4:03
1

It doesn't work because you broke it by fiddling with the settings. See:- How do I set up networking/WiFi/Static IP

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.