1

I am working on a project. And thetask is to collect the data from a washing machine using a raspberry pi. I have followed many tutorials, and for reference I have mentioned the steps below,

  1. Set up:

From the Machine : 3 wires comes out(DATA, VCC, GND) which is based on UART communication

RASPI: connected my computer and RASPI to common router and accessing RASPI via Putty terminal

UART PINS : In the RASPI Pin 10 : Connected to DATA pin of the machine and Pin 6: Connected to GND pin of the machine

I am not connecting the VCC pin of the machine to the RASPI (5v), once i blew a Pi by doing so !

  1. I disabled the serial console by following the link , https://github.com/lurch/rpi-serial-console

  2. I have also set the baud rate to 9600,

  3. I tried cat /dev/ttyAMA0 which shows me Junk Characters

ï· Ý[﷏ »Ã viáï· Ý[﷏ »Ã viá ï· Ý[﷏ »Ã viáï· Ý[﷏ »Ã viá `ï· Ý[﷏ #!/

  1. Tried to do a hexdump and this shows

sudo hexdump -C /dev/ttyAMA0

hexadecimal values, but the values are not the actual data which I am expecting !!

Can anyone help me with this ??

  • What are you expecting and why? This could be, e.g., serialized numerical values which you are treating as 1 byte characters. – goldilocks Apr 15 '16 at 20:29
  • Which model Pi? – Milliways Apr 15 '16 at 23:51
  • 1
    If you are using a Pi 3, you will also need to disable bluetooth. It has a debug mode that uses the UART pins. – Patrick Cook Apr 16 '16 at 18:39
  • Make sure you use a level-shifter - The Raspberry Pi IO Pin voltage levels are 3.3V. – Rasmus Friis Kjeldsen Apr 17 '16 at 12:12
1

No one has mentioned this yet and your details did not explicitly state what data-link layer is being used by the washer (rs-232,rs-485,etc)?

The term UART (universal asynchronous receiver transmitter) is what the circuits that send and receive async data are collectively called; it says nothing about the physical data layer standard being used.

  • I'm not really sure this is an answer, and maybe it should rather be a comment, but you might not have enough rep to place a comment, and I think you have a valid point, so I'm not going to flag it, but please be aware that this answer might be removed once the issue is resolved. – Bex Apr 17 '16 at 17:22
  • Please help me understand how one would actually answer a question that has none of the relevant information, without first posing a question that may or may not contain statements that clarify the context of the question? If this answer is raising red flags than I suggest that your moderation guidelines might need some work in concept or execution. – jim stewart Sep 24 '16 at 16:34
  • Hey @jimstewart your comments here in the "answer" are really useful. Bex was just saying that they are better suited to comments as this isn't actually an answer yet. Well. It's not a stackexchange answer which has a lot narrower definition of answer. Your answer is actually what people do in practice, i.e. answer with questions. On stackexchance that process is done in the comments or even chat section of the question itself. :) Thanks for contributing a great question to help RajuBhai ask a better question. – AJP Jun 14 at 21:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.