8

I purchased several Raspberry Pi 3s, reading the spec that their max resolution was 1920x1080.

I purchased several HP 22uh monitors to go with these, knowing their max resolution matches this.

On fully setting up my Pi, there is a 3/4" black frame around the border of the screen. For the parts displayed, the image is sharp, however I would like to use the full screen as the current display looks dumb.

I played around with the Pi and the monitor, and cannot find what settings adjustments will fix this.

Any ideas?

  • 1
    Have you tried changing the aspect ratio? There are also settings in the config.txt file that will fix this. – Darth Vader Apr 16 '16 at 7:37
  • Where is the config.txt file? Sorry, new to Pis – dthree Apr 16 '16 at 7:45
  • 1
    it is on boot partition – rav_kr Apr 16 '16 at 9:31
  • 1
    Assuming you are running Raspbian you can tun sudo raspi-config under advanced options is an overscan setting. – Steve Robillard Apr 16 '16 at 10:33
  • Thanks for the advice @SteveRobillard, that was spot on. – dthree Apr 16 '16 at 16:10
8

In your /boot/config.txt file try changing disable_overscan=1 and see what that does for the borders. If that does not help, leave disable_overscan=1 and then try changing these values as well.

overscan_left=20
overscan_right=20
Overscan_top=20
Overscan_bottom=20

It will take some trial and error to find the correct values because the correct values are monitor specific.

| improve this answer | |
2

Use negative values as described in the info in config.txt file

This worked for me

disable_overscan=1

overscan_left=-16
overscan_right=-16
Overscan_top=-16
Overscan_bottom=-16
| improve this answer | |
2

For Raspberry PI 4 B and Ubuntu 19.10, if you have black borders above and below:

vi /boot/firmware/usercfg.txt

Add the following line: disable_overscan=1

Reboot.

| improve this answer | |
0

I was also having the same problem at the beginning. I tried various methods and failed. I got a solution after I made a change in display settings. it worked for me.

check this article. https://www.hackerstec.com/raspberry-pi-display-black-border-troubleshooting/ follow this article it has a method that is not available in forums It has a tutorial on how to change screen settings and remove black border

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.