5

I newly installed (again) Raspbian from Noobs and updated, upgraded and dist-upgraded. After all of this i reboot my Pi and tried to sudo su and got

Segmentation fault

error. Tried rebooting and re-installing OS but every time when i distro upgrade it's happening.

What's the matter my Pi ? I searched on board and google but i only get it's a SD Card problem but when i did not upgrade distro, i can install apache etc and reboot and no problem after it.

Is my SD Card corrupted or something wrong with distro upgrading ?

Note: My upgrading way is;

apt-get update
apt-get upgrade -y
apt-get dist-upgrade -y

BTW: I cant even sudo halt... it's giving me same error.


Edit: My /etc/apt/sources.list content

 deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi
 # Uncomment line below then 'apt-get update' to enable 'apt-get source'
 #deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi
  • It's really weird. Can you show us your /etc/apt/sources.list ? – Huczu Apr 19 '16 at 7:26
  • @Huczu Updated answer with sources.list content – ahmetertem Apr 19 '16 at 22:03
3

The contents of your SD card is corrupt.

The only safe solution is to re-write the SD card from scratch.

Perhaps do a direct install of Raspbian Lite?

  • I already re-wrote multiple times and same error again and again. I'm not in an isolated network or something btw... What is the difference between Raspbian vs Raspbian Lite ? – ahmetertem Apr 19 '16 at 22:04
  • @ahmetertem I have to assume you have a faulty SD card. Raspbian Lite uses a lot less SD card space. A lot of bloat has been removed. I don't know what though. – joan Apr 19 '16 at 22:06
3

I formatted SD Card with SD Card Formatter and uploaded (wrote) via Win32DiskImager Raspbian Lite img and tried but same error. And I tried normal (not light) version too but still same error. Somehow my SD Card is corrupted.

I had same SD Card (same brand, same size) and tried Raspbian normal and it worked. I do not know still what is the exact problem but i know SD Cards can be corrupt.

  • Also formatted with sd card formatter and have the same symptoms. wget msg is just: "Speicherzugriffsfehler" – Honsa Stunna Sep 23 at 17:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.