i'm using mobaxterm to do some headless serving ala deluge, its been great for the past few days and weeks, some daily legal torrenting and do a auto shut down sequence for the like an hour of a duration of the download , but when i woke up this morning, i couldn't access my pi via SSH on the terminal, so i tried pinging it; its unreachable; tried different cables; same outcome; any thoughts on this? overheating ethernet chip? or idk?...i don't want my pi to die T_T :(

  • Have you tried turning it off an on again. Why do you make torrenting, sound more suspicious that it should be?
    – Impulss
    Commented Jan 22, 2013 at 1:31
  • how's that now? xD, jokes aside or any other normal downloads i.e manual patches and stuff, did it already on and off, this is the first time i've experienced this for the past few weeks since turning it on and setting it up
    – psyko666
    Commented Jan 22, 2013 at 1:34

2 Answers 2


Are you sure you're pinging the right address? Is it static? Is it possible the DHCP allocated a different address? Plug in a monitor, it could be a boot error too. If you plug the monitor in, it should tell you the IP address, if it's changed.

Otherwise, Check your router too, it should have a DHCP list; It might be vague, but it should give you an indication of which IPs to try and SSH if its been reallocated a different IP.

  • could be, i'll look for some monitors
    – psyko666
    Commented Jan 22, 2013 at 2:19
  • Otherwise bring your pi to the monitor might be easier. At least that will tell you if it's still booting properly.
    – Impulss
    Commented Jan 22, 2013 at 2:20
  • dude i could kiss you, although i did not use any monitor, the ip was changed thanks again cheers!
    – psyko666
    Commented Jan 22, 2013 at 2:23
  • i just looped through the list of addresses thanks again
    – psyko666
    Commented Jan 22, 2013 at 2:23
  • penguintutor.com/blog/viewblog.php?blog=6306 That link should help you to set a static IP, so this doesn't happen in the future. Glad it helped you! BTW torrents are for children, usenet is the way!
    – Impulss
    Commented Jan 22, 2013 at 2:24


If you know the hostname of your Pi (run hostname to find out) you can try reaching it using mDNS:

ping hostname.local

For example, if your Pi is named raspberrypi (the default) you would use:

ping raspberrypi.local

You could access the deluge web interface or daemon this way too; just substitute hostname.local for the ip address.

(This should work unless the avahi daemon on the Pi has been disabled for some reason).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.