1

I just got a new Raspberry Pi 3 with wifi. It works fine using the HDMI output, but I need to use it for a composite video project on an old PAL tv.

Just plugging it in with a composite video cable does not work, no output is visible. I have tried pushing 1,2,3,4 buttons, with and without shift.

I have edited config.txt as administrator, and added the line:

# pal mode
sdtv_mode=2

After rebooting, still no output is visible. The hdmi cable is not connected.

Could this mean the composite out is simply broken? The connector feels very loose. (The cable easily falls out).

  • The video out on the Pi 3 is HDMI only, how are you connecting it to a composite connector? – Darth Vader Apr 19 '16 at 15:02
  • I am using the composite video / audio out port. It has a little video icon so I assume that can be used for composite out, just like on the pi 2 :) – Kokodoko Apr 19 '16 at 15:07
  • There is only one video out port on the Pi 3 and that is the HDMI port. The exception to this is the display port, which requires a ribbon cable to plug into. There is also an 3.5mm analogue audio port which is audio only. – Darth Vader Apr 19 '16 at 15:10
  • OK, so this post does not apply to the Pi3? raspberrypi-spy.co.uk/2014/07/… – Kokodoko Apr 19 '16 at 15:15
1

I suggest this cable, it might work. Its essentially a 3.5mm to 3 x RCA.

I assume if the feature worked with the B+ they would have kept it for the Pi 2 and 3. There are also reviews on the same page that say the cable worked with the Pi 2.

If your trying to use an ordainary composite connector I think you might be out of luck

  • Thanks, I'm going to try to find this cable. The website that sells the PI3 mentions that it does have composite support. I hope I just used the wrong cable. – Kokodoko Apr 19 '16 at 15:53
  • After trying all kinds of different cables and settings, I have come to the conclusion that composite video does not work, at least not on my Pi... perhaps it's just broken... – Kokodoko Jan 15 '17 at 10:56
1

Could be that you have hdmi_force_hotplug=1 somewhere in your config.txt?

Mine had that line automatically added to the end during setup and commenting it out fixed the issue for me.

You could also try adding hdmi_ignore_hotplug=1, but I didn't have to...

Edit: Just to confirm, mine is a Raspberry Pi 3 and it definitely has composite output on the TRRS A/V (headphone) connector like you are expecting.

  • Thanks, I will check that! Currently the Pi is collecting dust, since I never got it working :) I'm afraid I might even have burned out the connector from trying out all kinds of different cables. – Kokodoko Aug 30 '16 at 16:43
1

Just in case anyone came across this and has the same issue (which I did) the solution is that the a/v cable is probably polarized incorrectly, ie swap the ground so it goes top the outside (shield) and video is to the center pin of the composite video connector

0

Looks like you got all the hard stuff already in the config.txt file. My problem was that they make 2 kinds of these types of cables with different pinouts. Try swapping the red and yellow connector on your TV. Good luck!

  • Thanks, I tried all possible combinations and even different cables. I guess it's just broken! – Kokodoko Jul 7 '17 at 12:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.