2

I just got a Raspberry Pi 3 and I am currently trying to mount my WD MyCloud EX2 to it and I am not having any luck.

I tried following this guide I found here

But I got this error: unable to find suitable address.

I attempted to edit the /etc/fstab file to this

192.168.1.119/WDMyCloudEX2/PiDownloads /home/ddrossi93/myNAS/myShare nfs 
workgroup=WORKGROUP,users,auto,user_xattr 0 0,username=admin,password=pw

and I now get the error: remote share not in 'host:dir' format.

I am not sure what I am doing wrong and could use some guidance.

EDIT: I got it to work, I had to turn on NFS access on my NAS

  • Seeing as you found the solution could you please make it an answer and mark it as correct. – Darth Vader Jan 30 '17 at 8:47
0

You should have // before 192.168.1.119. fs_mntops should be before fs_freq.

//192.168.1.119/WDMyCloudEX2/PiDownloads /home/ddrossi93/myNAS/myShare nfs workgroup=WORKGROUP,users,auto,user_xattr,username=admin,password=pw 0 0

Refer to the man page for fstab (5) for what fs_mntops and fs_freq are.

  • Hi there, thanks for the response. I am not sure what you mean by fs_mntops and fs_freq – ddrossi93 Apr 22 '16 at 23:03
  • nevermind I got it to work. I had to turn on NFS Access on my NAS. Thanks! – ddrossi93 Apr 22 '16 at 23:34
0

After doing what I listed in the description, I then found an option in the settings of the WD myCloud NAS to turn on NFS access. Once this was enabled, it mounted without any errors or issues.

0

You are right deciding to do it using fstab. I own a raspberry pi 1 and the same NAS as you. This is my fstab file content (for each network drive write a line):

//192.168.1.15/afolder /media/MyNAS/afolder cifs uid=myuser,credentials=/home/myuser/.MyNAS-credentials 0 0

As you can see, I store credentials in a separate file (/home/myuser/.MyNAS-credentials), which contains the following:

username=username
password=passwd
domain=WORKGROUP

Hope it helps!!

  • Hello, thanks for the response. I am still having some trouble. I am getting a parse error on the same line for the code I am posting. I am also getting this error as well, "mount.nfs: an incorrect mount option was specified" – ddrossi93 Apr 22 '16 at 23:05
  • 1
    nevermind I got it to work. I had to turn on NFS Access on my NAS. Thanks! – ddrossi93 Apr 22 '16 at 23:34
  • @Ddrossi93 could you thumbs up my answer and mark it as a correct answer, please? – russellhoff Jan 12 '18 at 8:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.