I use PuTTY and a Wi-Fi dongle to SSH into my Pi. It ALWAYS times out on the first attempt and then when I close PuTTY and re-open it, I can SSH into the Pi.

Any ideas why this is happening?



wlan0     IEEE 802.11bgn  ESSID:"Tom"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:2.442 GHz  Access Point: 30:46:9A:A2:59:D6
          Bit Rate:72.2 Mb/s   Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:****-****-****-****-****-****-****-****   Security mode:open
          Power Management:off
          Link Quality=100/100  Signal level=85/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

eth0      no wireless extensions.


Bus 001 Device 004: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  • 1
    do you mean first attempt after booting? wait a little longer after booting maybe? Commented Apr 22, 2016 at 4:12
  • maybe if you posted the session log?
    – JayEye
    Commented Apr 22, 2016 at 5:04
  • @JaromandaX It doesn't matter how long I wait. I could wait 10 minutes and I cant ssh into it first attempt. JayEye how do i get the session log? Commented Apr 22, 2016 at 5:43

2 Answers 2


Pi4,I use this command:

 sudo iw dev wlan0 set power_save off

Probably you got power saving mode enabled in your WiFi dongle.

You can check it in sudo iwconfig and turn it off: sudo iwconfig wlan0 power off , where wlan0 is your wifi card name in iwconfig list.

If it doesn't help tell us more about your WiFi dongle. Post iwconfig and lsusb by editing your post.

@Edit: Here was similar issue and this post helped:

  • I updated the post with info. When i tried running the power off command I got SET failed on device wlan0 ; Operation not permitted. And I ran it as sudo Commented Apr 23, 2016 at 1:56
  • Thanks for update. Here someone had similar issue with the same chipset and this post helped: raspberrypi.stackexchange.com/a/7760/42034 .
    – Huczu
    Commented Apr 23, 2016 at 10:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.