1

I'm trying to mount a windows share on a Raspberry Pi 3 running Raspbian Jessie.

As many others have stated, if I manually mount with sudo mount -a the volume mounts just fine. On a reboot, the mount fails.

I've tried the suggested fixes of:

  1. sudo crontab -e # and adding @reboot (sleep 30; /bin/mount /media/disk1)&.
  2. sudo nano /etc/rc.local and adding mount -a to the end of the file.
  3. I tried to edit the fstab entry to include comment=systemd.automount.

None of this has worked. Does anyone have any other suggestions before I turn this Pi 3 into a range target?

  • Solved...I need to add _netdev, x-system.automount I found numerous tutorials on mounting windows shares, but none of them contained that little gem above. Thanks to lightswitch05 for the advice in another thread. – Cheese1 Apr 22 '16 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.