1

Newbe here trying to learn Linux on Raspberry Pi 2B Jessie. While I can get the Front Center wave file to play with:

sudo aplay /usr/share/sounds/alsa/Front_Center.wav

When I try to play my wave files I get one of two errors:

No such file or directory, or file not found, even though I am in the folder where the wave file resides and have verified with ls as well as verifying the path as /home/pi. The service pulseaudio status results are:

pulseaudio.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)

I just want to play the wave files in my folder continuously in a loop.

I installed mplayer when aplayer produced those errors. No change. What am I missing? Trying to associate the player to the .wave files was unsuccessful as well. This is sure different from Windows where I could do this in 10 seconds!

ls-la /home/pi

total 222220

drwxr-xr-x 23 pi   pi        4096 Apr 23 05:08 .

drwxr-xr-x  3 root root      4096 Sep 24  2015 ..

-rw-r--r--  1 pi   pi    26460046 Feb 12 18:20 test 1.wav

-rw-r--r--  1 pi   pi    26460046 Feb 12 18:23 test 2.wav

-rw-r--r--  1 pi   pi    26460046 Apr 22 11:36 test 3.wav

-rw-r--r--  1 pi   pi    26460046 Oct 12  2015 test 4.wav

etc.

So researching file permissions I see these files as well as all files copied from a jump drive cannot be read. Does this mean all file permissions will have to be changed once copied onto the Pi? This also explains why the programs would not install. Is there a way to copy files and retain their permissions?

2
  • What is the output of ls -la /home/pi? Commented Apr 23, 2016 at 5:09
  • Try removing the space in the name. mv "test 1.wav" test_1.wav spaces make things harder on Linux and should be avoided. Commented Apr 23, 2016 at 17:50

1 Answer 1

-1

Try converting to MP4 they work. Use a site like clipconverter.cc then try again!! Try removing the space in the name. mv "test 1.wav" test_1.wav spaces make things harder on Linux and should be avoided.

6
  • If the wav player worked in his test why wouldn't they work with his own wav files. Commented Apr 23, 2016 at 17:59
  • @SteveRobillard not sure but try converting them, Commented Apr 23, 2016 at 18:00
  • If you look at his file names I would bet dollars to donuts the problem is the space in the file name. Which isn't a guess and explains why the test works but his files don't. Commented Apr 23, 2016 at 18:01
  • @SteveRobillard you have a point Commented Apr 23, 2016 at 18:02
  • Turns out it was the file permissions. Once I changed that parameter and took out the space the file played. Sure wish there was a "Pitfalls for Linux Newbes" out there. I still have not figured out how to associate the file to open with a program though, but that's a separate Java problem.
    – GranDy
    Commented Apr 23, 2016 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.