Ever since I made my Pi headless, and connected it to my laptop through Ethernet, I haven't been able to connect to the internet.

I followed this tutorial: https://pihw.wordpress.com/guides/direct-network-connection/

Using it I made my ethernet IP static, I can log into the pi from my laptop using SSH on that IP.

When I type hostname -I I get the following:

My Ethernet settings are as follows:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static

I don't know what the issue is, I've looked through other tutorials and troubleshooters, nothing seems to be working.


There are many issues with your configuration which I do not have time to explain. See How do I set up networking/WiFi/Static IP to explore some options.

The MAJOR issue is that you have specified a link-local address which is not routable i.e it only works over a single link.

If you have a router connect the Pi to this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.