I've got a raspberrypi zero with this Ethernet Network Adapter. It works fine but the speeds are very slow. On my laptop I can test my ISP's connection at about 50Mbps (down) 30Mbps(up).

But running speedtest-cli on debian jessie I can only get 4Mbps(down) 3Mbps(up).

  • Is there a way that I can improve this?
  • Is it a problem with the Ethernet Adapter itself?
  • Can I improve bandwidth with a WLAN usb Dongle?

here is the result of lsusb:

Bus 001 Device 002: ID 0fe6:9700 Kontron (Industrial Computer Source / ICS Advent) DM9601 Fast Ethernet Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

UPDATE: I've tried to power the pi with a nexus 5 charger and a ipad charger. Got the same (slow) results. I've plugged the Ethernet Network Adapter to my laptop running win 7. And got the very same (slow) results. So 2 different OS with same results? Poor hardware?

Current with WLAN: enter image description here With the Ethernet Network Adapter: enter image description here

  • Try to set max_usb_current=1 in /boot/config.txt and reboot device. This should increase power output over usb port to maximum.
    – Huczu
    Commented Apr 26, 2016 at 13:50
  • now that you mention this...I'm powering the pi0 with the router's usb port. Since 'it worked', I thought that was ok...could that be the reason? maybe disabling HDMI might save me some power as well?
    – Txugo
    Commented Apr 26, 2016 at 14:15
  • 1
    According to raspberrypi.org/forums/viewtopic.php?f=63&t=128842 it should work. If you are powering from router's usb port it could be reason because it's not giving enough power for USB.
    – Huczu
    Commented Apr 26, 2016 at 14:30
  • 1
    it's bites. but nice thinking.
    – Txugo
    Commented Apr 27, 2016 at 9:25
  • 2
    the DM9601 needed a kernel patch to avoid the Pi random crashing at high speed, but I have not revisited it since last year. jumpstation.co.uk/flog/Jan2015.html#p180120151628 I detailed how to build and apply the kernel patch jumpstation.co.uk/flog/Jan2015.html#p190120151932 Hope that helps.
    – rob
    Commented Apr 28, 2016 at 8:04

1 Answer 1


A lot of the USB to Ethernet adapters available from China (via EBay or Amazon) have old chipsets that are actually USB1 and this limits the potential speed that you can get.

Given you've tried the adapter on a second, more capable, computer I would suggest the problem lies with the Chinese adapter you're using.

You might want to try the likes of Pimoroni (who specialise in Pi stuff) to see if there's a proven adapter on sale there...


I bought this Pimoroni product and tested it using ArchLinuxARM with a PiZero, Pi Model B 256MB and Pi Model B 512MB (I don't have a more recent Pi model). Here are the results I experenced:

test A : nc (pacman -S gnu-netcat)

  • client: nc -vvlnp 12345 >/dev/null
  • server: dd if=/dev/zero bs=1M count=1K | nc -vvn client_ip 12345


PiZero:  202.867s     5.3MB/s 42.4Mb/s
PiB256:  323.495s     3.3MB/s 26.4Mb/s
PiB512:  325.257s     3.3MB/s 26.4Mb/s
IntelX86: 91.2377s, 11.8 MB/s 94.4Mb/s

test B : iperf (pacman -S iperf)

  • client iperf -c server_ip
  • server iperf -s


PiZero:   94.0 Mbits/se
PiB256:   57.6 Mbits/sec
PiB512:   58.0 Mbits/sec
IntelX86: 94.1 Mbits/sec

So it would appear that the PiZero with this adaptor outperforms the ModelB.

(compare the above with the 100-baseT ethernet theoretical maximum of 100Mb/s or 12.5MB/s.)

According to labelling, the chipset in this product is a RealTek 8152B. Identifiable product code is YS-LAN26 RT8152B.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.