0

When I start my Pi, it boots to text and asks for the password. How do I start graphical version?

I tried holding the shift key when starting up, but it didn't change anything.

1

You can change how your Pi boots using the raspi-config script.

  1. From a command prompt start raspi-config by typing the following:

    sudo raspi-config
    
  2. select option 3 Boot Options,

  3. then select option 3 Desktop or Desktop Autologin (The first will require the password, the second will not).

  4. Click Ok and

  5. click Finish to exit raspi-config.

Finally reboot to test your changes.

FYI holding down the shift key determines whether the Pi boots to safe mode.

0

If you just need to start it once:

sudo service lightdm restart

Assuming you are using the standard Raspbian.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.