1

Newbie to the Pi so this may be a dumb question.

Hardware: Raspberry Pi 3

In following the suggestions to use "sudo apt-get update" the update system seems to be stuck. I keep getting updates for Jessie which seem to repeat forever. I have tried restarts and the system seems to think the patches haven't been applied.

Is this something I can address or do I need to wait for the Jessie maintainers to fix something?

Here is an example Terminal Session, my entries are Bold:

pi@rasp-pi-01:~ $ sudo apt-get update

Hit http://archive.raspberrypi.org jessie InRelease

Hit http://mirrordirector.raspbian.org jessie InRelease

Hit http://archive.raspberrypi.org jessie/main armhf Packages

Hit http://mirrordirector.raspbian.org jessie/main armhf Packages

Hit http://archive.raspberrypi.org jessie/ui armhf Packages

Hit http://mirrordirector.raspbian.org jessie/contrib armhf Packages Hit http://archive.raspberrypi.org jessie/staging armhf Packages Hit http://mirrordirector.raspbian.org jessie/non-free armhf Packages Hit http://mirrordirector.raspbian.org jessie/rpi armhf Packages Ign http://archive.raspberrypi.org jessie/main Translation-en_GB Ign http://archive.raspberrypi.org jessie/main Translation-en Ign http://archive.raspberrypi.org jessie/staging Translation-en_GB Ign http://archive.raspberrypi.org jessie/staging Translation-en Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB Ign http://archive.raspberrypi.org jessie/ui Translation-en Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB Ign http://mirrordirector.raspbian.org jessie/main Translation-en Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en

Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB

Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en

Reading package lists... Done

pi@rasp-pi-01:~ $ sudo apt-get dist-upgrade

Reading package lists... Done

Building dependency tree Reading state information... Done

Calculating upgrade... Done

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. pi@rasp-pi-01:~ $

3

Instead of dist-upgrade (which would upgrade your distro e.g. wheezy to jessie) try sudo apt-get upgrade (after update)

Basic functionality for apt-get

update: fetch up packages versions on repositories you have

upgrade: compare updated versions with current installed ones and upgrade'en

dist-upgrade: compare distro version and upgrade it

  • Huczu awnser is correct, I guess. Your question kind of leaves it open for interpretation. – Felício Apr 27 '16 at 12:50
  • Ah, update vs upgrade. interesting. – DuckPaddle Apr 27 '16 at 12:52
  • Yup, kinda confusing when coming from windows, had the same doubt first time using linux. It makes a lot of sense though – Felício Apr 27 '16 at 12:54
  • Yep, I am from Windows and having command lines make sense is a novel experience! – DuckPaddle Apr 27 '16 at 12:57
3

To explain what sudo apt-get update is doing please read: What does “sudo apt-get update” do?

To update your system you should use sudo apt-get dist-upgrade after doing an update of repository.

If it stuck please edit your post and paste logs from update command.

@edit:

After edit I see everything is OK. Your repository has been updated to actual without errors. Next you tried upgrade your dist and apt-get tells you everything is up to date.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.