1

I'm trying to get a small fan to work with the Raspberry Pi 2 using power off of the GPIO pins. The fan seems to work fine on the boot, but NOOBS itself won't boot. It gives me the following message.

sh: can't access tty: job control turned off
/ #

Here's some diagrams of how I have my fan connected to the GPIO pins.

m

I've tried a few solutions so far, I knew that it was just the safe mode in NOOBS.

Here are the two that I've tried

  • Added avoid_safe_mode=1 in the config.txt file.
  • Added disablesafemode in the recovery.cmdline.

This is what the recovery.cmdline file looked like after it was edited.

quiet vt.cur_default=1 elevator=deadline
disablesafemode

I've a feeling that it isn't drawing too much current, the red led is solid throughout the booting process and continues to stay solid when it's finished booting. I can unplug the fan from the pins and it'll boot fine, in fact, I can even plug in the fan after the boot process and everything will work fine. It's annoying to have to unplug it and plug it in each time though.

  • 3
    It might be drawing too much current. – PNDA Apr 28 '16 at 4:37
  • Does NOOBS boot when the fan is not plugged in? If so there may be a clue there. – joan Apr 28 '16 at 7:20
  • 2
    Correction: It is drawing too much current. – PNDA Apr 28 '16 at 11:24
  • @PandaLion98 I actually don't think it's drawing too much current. The red light stays solid throughout the booting process and the fan still works. In fact, I can boot fine without the fan plugged in and then I can plug the fan in after the booting process finishes. Everything works fine after that. I honestly think it's NOOBS safety with the pins. – Zachary Vincze Apr 28 '16 at 11:31
  • @PandaLion98 Just a thought. – Zachary Vincze Apr 28 '16 at 11:32
3

It is drawing too much current!

You may be able to use a bigger supply (there are limits) but as you don't need a fan in the first place don't use one.

PS You are NOT using "GPIO pins" but power pins on the expansion header.

  • I don't think so, it would've given me another error message if it was drawing too much current. I've read about safe mode not allowing you to draw power from certain pins. elinux.org/RPI_safe_mode Also, if it was drawing too much current, the red power led on the computer shouldn't stay solid. Right? – Zachary Vincze Apr 28 '16 at 12:11
  • If something is drawing too much power from Pi, it doesn't give you ANY error. Believe me, I have tested raspberry Pi for a few years now in different configurations. For example, my external HDD requires an USB hub with another 5V power supply. – machineaddict Apr 28 '16 at 13:19
  • @machineaddict So, if it doesn't give any error. Does the message a posted in my question relate to drawing too much power? Because that's what I'm trying to get at. – Zachary Vincze Apr 28 '16 at 13:42
  • @machineaddict Actually, I might have put defaultsafemode on a separate line when it should've just been one big line. I'll have to confirm when I get back to having access to the Pi again. I'll also consider your idea if that doesn't work. Thanks. – Zachary Vincze Apr 28 '16 at 13:46
0

I've figured it out, my plan of adding disablesafemode to that file works only when they are on the same line together, it was only a minor mistake. Everything seems to be working fine now.

For anyone else having this problem, here's what you can do.

  • Add avoid_safe_mode=1 to the config.txt file located in the boot partition of your Raspberry Pi. Although this didn't work for me, it may work for you.
  • Add disablesafemode on the same line as the rest of the text in the recovery.cmdline file located on the recovery partition of your Raspberry Pi. Your file should look like this.

quiet vt.cur_default=1 elevator=deadline disablesafemode

  • The last thing to do is to find a different power supply as suggested in the other answers. It may be drawing too much current from the computer not allowing it to boot.

Note: If you want to edit the files on the recovery partition, you have to put the Micro SD card into your computer. The text files can be edited with any text editing program.

Good luck!

0

Looking at the specification for a F251R at this site https://www.digikey.com/catalog/en/partgroup/f251r-f251rf-and-f251t-series/340 suggests that the fan will draw between 20 and 60 mA if it is one of the 5V types.

IIRC that could be within the capabilities of the 5V supply once it is up and running which, indeed, does to be the case as you have found.

However it seems that there must be issues on the load it presents on either it spinning-up at start-up (some types of motor do draw significantly more current until they are up to speed) or perhaps there is an overload during the phase when other things intrinsic to the RPi are starting up...

As a solution to this - assuming you really do need to have a cooling fan - which is hard to believe - you might arrange to control the fan with a transistor which is controlled via a GPIO pin that is only switched to the active state when the RPi has finished booting up and is running normally. After that, you might as well go the whole way and have a temperature sensor and then only switch the fan on when needed...!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.