2

I run the following command:
uv4l --driver uvc --device-id '0458:7081'
It seems to be working, but I've no idea how to define lower fps to reduce traffic. The manual didn't help. The distro is Debian Wheezy.

1 Answer 1

1

You can use v4l2-ctl in the V4L2 tools collection to set the frame rate to one allowed value.

5
  • Thanks. The following commands helped: v4l2-ctl --set-fmt-video=width=1280,height=720,pixelformat=1 && v4l2-ctl --set-parm=8 where pixelformat was determined by: v4l2-ctl --list-formats
    – beemaster
    Apr 29, 2016 at 6:18
  • Unfortunately I obtained that v4l2-ctl settings sometimes are being ignored by uv4l. Moreover, uv4l removes module 'uvcvideo' so after rebooting 'v4l2-ctrl' can't be applied until the module loaded manually (because there is no file '/dev/video0'). Also there is --configuration param available for uv4l uvc driver. What syntax of arguments for this param?
    – beemaster
    Apr 29, 2016 at 15:27
  • 1
    you are mixing stuff: uvcvideo is the kernel driver, while uv4l-uvc is the userspace driver. they are mutually exclusive.
    – prinxis
    May 2, 2016 at 0:48
  • So what's the actual parameter for frame rate in v4l2-ctl?
    – matanster
    Jan 12, 2021 at 8:32
  • For those wondering, v4l2-ctl --set-parm=8 is the one that sets the frame rate. In this case, it's 8.0 FPS.
    – MrWm
    Mar 20, 2021 at 22:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.