3

I've tried fresh installs of Debian, Debian Lite and Ubuntu Mate, but my wifi doesn't show up.

In Debian Lite I followed this guide: https://www.raspberrypi.org/documentation/configuration/wireless/wireless-cli.md

In Ubuntu Mate I tried plugin in an ethernet cable to upgrade everything possible, but it didn't help.

I can see lots of other wifi networks, but mine is not showing up.

This is my wifi info, seen from OSX. It is not a hidden network.

enter image description here

3
  • Do you see your wlan if you run iwlist scan in a terminal?
    – ott--
    Apr 29 '16 at 23:05
  • 1
    sudo apt-get install crda enabled 12, 13
    – Milliways
    May 30 '16 at 0:12
  • This might be a duplicate of this question.
    – Cerin
    Jun 10 '17 at 18:56
8

There is a bug in current software/firmware which prevents the on-board WiFi from running on Channel 12.

Channel 12 & 13 are not available in all countries. There is a WiFi Country setting in raspi-config but unfortunately it does not work with the current firmware.

Some users have reported success, but this may be related to those using the latest pre-release firmware.

EDIT Even after upgrading to 4.4.9 I still had only channels 1-11.

Installing sudo apt-get install crda enabled 12, 13

2
  • Very accurate, thanks. Switched to another channel and it worked fine. Do you know where I can track the progress of this bug?
    – Znarkus
    May 1 '16 at 12:42
  • Many thanks for your explanation. Function perfect for me, in Raspberry pi 3 b with Kali.
    – Alejandro
    Sep 1 '17 at 21:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.