0

After following this guide here, I am having no success with the audio from my phone appearing through the audio device connected to my raspberry pi 3. The audio is evidently being transmitted through pulse audio as the volume is raising and dropping however: i cannot hear it in my earphones.

The device that the audio is being transmitted to is bcm2835 ALSA Analog stereo, is this my headphones? And i am sure of this because the audio mixer(pavucontrol) shows movement insync with the sounds playing from my phone.

What could be wrong here?

UPDATE: Turns out no audio played on raspberry pi comes out of the audio output.

1

Did you try running "amixer cset numid=3 1" to set the output to the audio jack.

If that didn't work try the setting the audio output to another interface such as HDMI, if this works then you know that the problem is with the audio jack. Just make sure to use "amixer cset numid=3 2" to set the ouput to HDMI.

Have a look at this page here for more details.

  • Hi Jack. Tried all this, still no luck. I dont have hdmi sound available on my screen – Oliver Kuchies Apr 30 '16 at 9:46
  • Does the audio jack work for any other programs with sound? – James Martin Apr 30 '16 at 10:09
  • Havent tried any other programs with sound. Quite new to the pi. Any suggestions for a good program to test? If no luck with sound, what would be a viable solution? – Oliver Kuchies Apr 30 '16 at 10:12
  • Make sure the output is set to the audio jack and run "speaker-test -c2 -t wav" to test if the headphones are working. – James Martin Apr 30 '16 at 10:18
  • Hi @James Martin , Thanks for your response! No- the headphones aren't working. But they work on other PC's. Do you think its a driver problem or a physical problem? – Oliver Kuchies Apr 30 '16 at 10:26
1

The 3.5mm output jack on the Pi is unique. See this link: http://www.raspberrypi-spy.co.uk/2014/07/raspberry-pi-model-b-3-5mm-audiovideo-jack/

  • Hello and welcome. While I would not go so far as to call it unique (think iPods and stuff also use 4-pole sockets), this could be something the OP might want to look into. – Ghanima Apr 30 '16 at 20:38
  • The audio cable i have been using has 3 bars too. – Oliver Kuchies May 1 '16 at 22:51
0

I would definitely try plugging the Pi into an HDMI audio device and see if you get sound.

Is the default user added to the audio group?

usermod -a -G <goup name> <username>

Try sudo raspi-config Go to Advanced / Audio and force the 3.5mm jack as your output.

  • Unfortunately still no luck :/ – Oliver Kuchies Apr 30 '16 at 9:46
0

You could try forcing audio through the 3.5mm jack.

Here's how this is done.

  1. Open up the Raspberry Pi configuration menu by entering sudo raspi-config.
  2. There should now be a menu that's popped up. This is the Raspberry Pi configuration screen. Select option 8 Advanced Options and press enter.
  3. Select option A6 Audio and press enter once again.
  4. From there you should be able to change wether the audio is forced through HDMI or the 3.5mm Jack.

If this didn't work, try taking a look at this to see different solutions and for more information on this subject.

Good luck.

0

It seems PulseAudio is interfering with AlsaUtils - After removing PulseAudio my sound works. I re-installed PulseAudio after ensuring AlsaUtils is installed first and the problem has been resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.